Closed Bug 12312 Opened 21 years ago Closed 21 years ago

{inc} Resize page and HR moves up

Categories

(Core :: Layout, defect, P2)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cpratt, Assigned: buster)

References

()

Details

Attachments

(3 files)

Build ID: 1999082008
Platform: all

To reproduce: Load one of the above URLs (Netscape internal only, sorry). When
the page has finished loading, click Reload.

Result: When the page reloads, the horizonal rule moves down and then back up;
the images beneath it are also drawn twice, once lower, and then higher up on
the page. (I'm guessing that the problem is that when the CSS styles contained
in default.css are applied, the page redraws and lays out differently).

Expected result: As with Communicator 4.x, when the page is reloaded, objects on
the page should not move around on the page.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Looking at the pages in viewer.exe I don't see the problem you describe

If it happens in apprunner, but not viewer then it's not necessarily a layout
problem and someone on apprunner should look at it
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
My bad. I was using apprunner and not viewer. To whom should I reassign the bug?
Did it work okay for you, too, when you used viewer? I'm assuming so

I don't know who is the point person for apprunner issues. Maybe
don@netscape.com and XPApps?
Status: REOPENED → ASSIGNED
I rep
Assignee: troy → kipp
Status: ASSIGNED → NEW
Whiteboard: [incr]
I reproduced the problem in viewer. It's an incremental reflow problem. I'm
attaching a very small test case (no images even) that show that the problem is
because of the empty paragraph.

Kipp, resize the window and you'll see the HR move up
Summary: When page redrawn, images move around (using CSS) → {inc} Resize page and HR moves up
Whiteboard: [incr]
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M11
Status: ASSIGNED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Fixed by checkins relating to 12890
Status: RESOLVED → VERIFIED
Fixed in the Sept 13th build.
You need to log in before you can comment on or make changes to this bug.