currently there's a pref called: user_pref("pref.browser.smartbrowsing.disable_textbox.add", false); there's absolutely no need to include the "pref" word into a prefs...! The pref should be renamed to: user_pref("browser.smartbrowsing.disable_textbox.add", false); This way the pref will also be located next the the other browser prefs in the prefs.js file. 20020201 btw: I'm CC'ing the people that seems to be contributers to the file where the pref is used: http://lxr.mozilla.org/seamonkey/source/xpfe/components/prefwindow/resources/content/pref-smart_browsing.xul#70 NOTE: Is the pref actually used???? http://lxr.mozilla.org/seamonkey/search?string=disable_textbox seems to only get one hit!
How do you propose we handle backward compatibility? More code to convert older profiles? That seems like code bloat for a name we would like to have aligned with others. Is there some end user benefit?