Romanian keyboard: AltGr+T opens a new tab instead of inserting diacritic ț

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: silviubogan, Unassigned)

Tracking

45 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

1. Set the keyboard layout to Romanian (Programmers) on Windows 7 SP1 x64.
2. Open Firefox.
3. Go to http://www.google.com .
4. Press AltGr(Right Alt)+t.

Relevant link: http://www.wikiwand.com/en/AltGr_key


Actual results:

A new tab is opened and nothing is inserted in the Google search input.


Expected results:

The "ț" character should have been inserted in the Google search input and a new tab should not be opened.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Build ID 	20151213030241
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0

Hi, 
I tested this problem on Win 7 x64 with FF Nightly 45.0a1 and I can reproduce this problem. To reproduce this you need to set your keyboard to Romanian and when you want to push rightALT +T you should have the "ț"  but FF opens "tools". I have tested on Chrome and it works as expected.
Status: UNCONFIRMED → NEW
Component: Untriaged → Keyboard: Navigation
Ever confirmed: true
Product: Firefox → Core
Version: 42 Branch → 45 Branch

Updated

3 years ago
See Also: → bug 1233948

Comment 2

3 years ago
Created attachment 8700303 [details]
google.jpg

WFM with FF43 and Romanian (Programmers) keyboard on Win 7.
Duplicate of this bug: 1233948
Build ID 	20151220030223
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0

Hi,
I retested this on Win 7 x64 with FF Nightly 46.0a1 and I can't reproduce the problem. 
Reporter please test again with FF 43 or FF Nightly to see if you can reproduce the problem. Use this links for download the versions: https://nightly.mozilla.org/     https://www.mozilla.org/en-US/firefox/new/
Flags: needinfo?(silviubogan)
(Reporter)

Comment 5

3 years ago
Created attachment 8700642 [details]
firefox_debugging_info.txt

I tested in Firefox 43.0.1 x64 on Windows 7 SP1 x64 and in Safe Mode the issue does not exist, but when using Firefox in the normal mode, the problem is still there. I attached the debugging info.
Flags: needinfo?(silviubogan)
Hi,

I see from your attachment that you have more add-ons installed, when you start in Safe Mode all this add-ons are disabled, so this problem may be related with your add-ons. You can try to disabled one by one and see which cause the problem.
Flags: needinfo?(silviubogan)
(Reporter)

Comment 7

3 years ago
The add-on that causes the problem is this:
https://addons.mozilla.org/ro/firefox/addon/open-tabs-next-to-current/
https://github.com/sblask/firefox-open-tabs-next-to-current

I opened a new issue in the GitHub repository linked above: https://github.com/sblask/firefox-open-tabs-next-to-current/issues/9 .
Flags: needinfo?(silviubogan)
Component: Keyboard: Navigation → Add-ons Manager
Product: Core → Toolkit

Comment 8

3 years ago
This isn't a problem with add-ons manager, but with the add-on in question.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.