When trying to change the OS type in the bug form mozilla segfaults

VERIFIED DUPLICATE of bug 122796

Status

()

Core
Layout: Form Controls
--
critical
VERIFIED DUPLICATE of bug 122796
16 years ago
16 years ago

People

(Reporter: Sven Esbjerg, Assigned: rods (gone))

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
I was trying to bug report mozilla-sparc-nightly when mozilla on my freebsd
machine crashed. This happens when I'm choosing a different OS from the
drop-sown menu. When I use the scrollbar mozilla crashes.

Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:0.9.8+) Gecko/20020202, build
2002020207

gdb backtrace:
(gdb) bt
#0  0x295f670f in handle_gdk_event () from
/opt/mozilla/components/libwidget_gtk.so
#1  0x2847be9d in gdk_event_dispatch () from /usr/X11R6/lib/libgdk12.so.2
#2  0x284ab1ef in g_main_dispatch () from /usr/local/lib/libglib12.so.3
#3  0x284ab81d in g_main_iterate () from /usr/local/lib/libglib12.so.3
#4  0x284ab9d0 in g_main_run () from /usr/local/lib/libglib12.so.3
#5  0x283c69aa in gtk_main () from /usr/X11R6/lib/libgtk12.so.2
#6  0x295ef380 in nsAppShell::Run () from
/opt/mozilla/components/libwidget_gtk.so
#7  0x2879f0d2 in nsAppShellService::Run ()
   from /opt/mozilla/components/libnsappshell.so
#8  0x805081f in DoCommandLines ()
#9  0x80511e4 in main ()
#10 0x804c671 in _start ()

Comment 1

16 years ago
hmm looks like a dup of bug 122796, but the fix was checked in (or rather backed
out) on Jan 31st.
Assignee: asa → rods
Component: Browser-General → HTML Form Controls
QA Contact: doronr → madhur

Comment 2

16 years ago
reporter: i noticed you filed two later bugs with build 2002013122
Can you reconfirm that the crash you see here in bug 123148 actually occur with
build 20020202?
(Reporter)

Comment 3

16 years ago
Hmm... works in:
Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:0.9.8+) Gecko/20020203, build
2002020307

*** This bug has been marked as a duplicate of 122796 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.