Closed Bug 12315 Opened 21 years ago Closed 20 years ago

viewer unable to open empty file

Categories

(Core :: Networking, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: Brade, Assigned: warrensomebody)

Details

(Whiteboard: help wanted)

I thought I had a file with html in it named:  test.html
I tried to open this file in Viewer but it just spun its wheels.  The file
actually had no data in it.

To reproduce:
  * create a file with no data in it; name it:  test.html
  * open this file in viewer
by the way, I don't know if any of the following are bugs today but historically,
I remember seeing problems with other "special" files like:
 * those with only spaces in them
 * those with only 1 space in them
 * those with only blank lines (cr/lf) in them
 * those mislabeled as html though they have no tags in them (just text)

paulmac--you may want to create some of these testcases if they don't already
exist.  The test cases should be run in both browser and editor modes.
Status: NEW → ASSIGNED
Whiteboard: help wanted
Target Milestone: M12
any volunteers to take a first shot at this?
I remember that the whole new file stuff had problems mit empty files, but that
was a while ago. This can easily be tested with TestFileInput. I will check
again when I return home
Empty files in general seem to work with necko now. And this seems not to be a
linux problem, no problems loading empty pages or other "special" pages with
viewer.
Moving Assignee from gagan to warren since he is away.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Works for me in both viewer and apprunner.
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.
Status: RESOLVED → VERIFIED
verified
You need to log in before you can comment on or make changes to this bug.