Closed Bug 1231523 Opened 4 years ago Closed 2 years ago

Selecting share button for a video from a Bing or Duck Duck Go search will cause orientation issues

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-master --- affected

People

(Reporter: jthomas, Unassigned)

References

()

Details

(Keywords: polish, Whiteboard: [2.6-Daily-Testing][Spark][Systemsfe])

Attachments

(1 file)

Description:
If the user plays a video using Bing or Duck Duck Go in the rocket bar and attempts to share the video the share buttons will have no response. From here switching from Portrait into Landscape mode will then show some orientation issues. 


Repro Steps:

Prereq: Wifi OR Data enabled

1) Update a Aries to 20151209121803
2) From Settings change browser to Bing OR Duck Duck Go.
3) Search for a video in the rocket bar. (Do not go to directly to YouTube.)
4) Select Videos from Bing or Duck Duck Go's results.
5) Play Video.
6) Maximize Video.
7) Select the Arrow pointing to the right icon located at the top right of the video.
8) Select the "..."
9) Rotate device in Landscape


Actual:

Bing: Video will appear chopped in Landscape mode with the right side of the video being black.

Duck Duck Go: Video will appear chopped in Landscape mode with the right side of the video being white.


Expected:
It is expected that the video will be able to change from this screen to landscape with the proper orientation.

Environmental Variables:
Device: Aries 2.6
BuildID: 20151209121803
Gaia: 961528f4391668bc89ec0be14fa367cea099b588
Gecko: 319be5e7ce3061c7c16f24d750b6dacdbcac4c35
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 
See attached: Logcat & Video

Video: https://youtu.be/BpjUR5mWVmU
This issue DOES occur on Flame master.
Result: Video will not appear in landscape correctly.

Environmental Variables:
Device: Flame 2.6 Fullflash (512mb)
BuildID: 20151209030343
Gaia: 961528f4391668bc89ec0be14fa367cea099b588
Gecko: 319be5e7ce3061c7c16f24d750b6dacdbcac4c35
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

----------------------

Unable to verify this issue with Flame 2.5 and 2.2. I have been unable to maximize the video using Bing or Duck duck go..

Environmental Variables:
Device: Flame 2.5 Fullflash (512mb)
BuildID: 20151209170211
Gaia: 7ca639a7bb0bacf27f548841c52617bfc0e3b21f
Gecko: a35e8eb98969970d1af28b265bf99a9edd11e9c2
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.2 Fullflash (512mb)
BuildID: 20151209032501
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 4381c4b69b9c
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Whiteboard: [2.6-Daily-Testing][Spark][Systemsfe]
I'm not sure this is a blocker but it is a pretty bad user experience.  Nominating for now, but can I get your opinion Alison?
blocking-b2g: --- → 2.6?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(ashiue)
Not a blocker since its not a regression.
blocking-b2g: 2.6? → ---
Keywords: polish
Priority: -- → P1
Flags: needinfo?(ashiue)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.