Closed Bug 123155 Opened 20 years ago Closed 19 years ago

Mozilla eats up CPU

Categories

(Core Graveyard :: GFX, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 110113
Future

People

(Reporter: braden, Assigned: kmcclusk)

References

()

Details

(Keywords: crash, perf, testcase)

Attachments

(3 files, 1 obsolete file)

108.20 KB, image/png
Details
750 bytes, image/png
Details
484 bytes, text/html
Details
Something about this page is making Mozilla peg the CPU.
confirming using build 2002020103 on Win2k.
OS -> All.
This is because of background images (guess they use alpha as they're png-based)
defined in semblance.css:

html {
  background-image: url("fade-to-gnome.png");
[...]
body {
  background-image: url("fade-to-grid.png");

Loading site without these images make it work fine (CPU remains at 10 to 0%).

Dupe of bug 96633, bug 90198 ?
Keywords: perf
OS: Linux → All
I'm seeing the same behavior on build 2002020208 PC/Linux.
We spend most of that CPU time inside:

510   48.6%     nsImageGTK::DrawComposited32
153   14.6%     readv
152   14.5%     gdk_rgb_convert_0888

on Linux.
Assignee: asa → kmcclusk
Component: Browser-General → Compositor
QA Contact: doronr → petersen
Target Milestone: --- → mozilla1.1
Bulk moving Mozilla1.2 bugs to future-P2. I will pull from this list when
scheduling post Mozilla1.0 work.
Priority: -- → P2
Target Milestone: mozilla1.1 → Future
Bulk moving Mozilla1.1 bugs to future-P2. I will pull from this list when
scheduling post Mozilla1.0 work.
Using build 2002041903 on win-xp,1.1ghz,512RAM,32MB GeForce2 Go the site is 
unusable (mouse-cursor is hog & jumps around when moving)

Same on Windows 2000 and Mac OS 9, changing Platform to All.
Hardware: PC → All
I've observed loading this page precipitating a crash; though I haven't been
able to nail down the precise circumstances under which the crash will occur.
Severity: major → critical
Keywords: crash
could patch for bug 143046 help a little (eventhough it doesn't seem to affect
PNGs) ?
This is weird... A week ago I did have problems loading this page, but today
(1/14/03)it loads like a charm on all platforms (Linux, Win XP and MacOS9)using
the 1/08/09 Trunk builds. I wonder if this is not a networking/server problem,
because the page, even with remote URLs, loads quickly as a test case. See
attached testcase.
Keywords: testcase
Attached file testcase (obsolete) —
Yes, I changed the page. I'll work up a testcase.
Carine: What are you testing in your testcase? This is an image compositor bug.
Attached image First sample image.
Attached image Second sample image
Attached file Test case.
Comment on attachment 111531 [details]
testcase

Please don't zip test cases.
Attachment #111531 - Attachment is obsolete: true

*** This bug has been marked as a duplicate of 110113 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.