PDF.js: bad rendering of unordered list bullets

RESOLVED FIXED in Firefox 45

Status

()

Firefox
PDF Viewer
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Piotr Janik, Unassigned)

Tracking

42 Branch
Firefox 45
x86
Windows
Points:
---

Firefox Tracking Flags

(firefox44 affected, firefox45 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8697244 [details]
document.pdf

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

Open or print an iText-on-Primefaces-generated PDF (see the attachment) (various computers, Windows XP & 7, various printers from the HP LJ & Konica Minolta families)


Actual results:

The default bullets in HTML unordered lists are rendered as, well, little bullets instead of discs.


Expected results:

The default bullets in HTML unordered lists should be rendered as discs.
(Reporter)

Updated

2 years ago
Component: Untriaged → PDF Viewer
OS: Unspecified → Windows
Hardware: Unspecified → x86
Summary: PDF.js: rendering & printing to paper issues → PDF.js: rendering HTML unordered list bullets

Comment 1

2 years ago
Created attachment 8697252 [details]
screenshot-ff42.png

Page #12, FF42 Win 7.

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: PDF.js: rendering HTML unordered list bullets → PDF.js: bad rendering of unordered list bullets
Fixed in https://github.com/mozilla/pdf.js/pull/6651
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Depends on: 1232015
Target Milestone: --- → Firefox 45
Duplicate of this bug: 1095796
QA Whiteboard: [good first verify]
status-firefox44: --- → affected
status-firefox45: --- → fixed

Comment 4

2 years ago
I have reproduced this bug with Firefox Nightly 45.0a1 (Build ID:20151210030212) on 
windows 8.1 64-bit with the instructions from comment 0.

Verified as fixed with latest Firefox beta 45.0b3 (Build ID: 20160204142810)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
QA Whiteboard: [good first verify] → [good first verify][bugday-20160210]
You need to log in before you can comment on or make changes to this bug.