Closed Bug 1231712 Opened 4 years ago Closed Last year

Hold the content process alive when a service worker is running

Categories

(Core :: DOM: Service Workers, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1438945

People

(Reporter: ehsan, Assigned: ehsan)

References

(Blocks 1 open bug)

Details

Consider this example:

1. We start a SW.
2. ContentChild::ActorDestroy() is called.

Currently ContentChild::ActorDestory() kills the content process.  We need to maintain a counter of some sort in order to make sure that in the case above, the content process stays alive as long as all SWs and the ContentChild are alive.
Why is this a blocker for beta?  This does not seem like an immediate short term problem.

We also already have bug 1231213.
Flags: needinfo?(ehsan)
It doesn't need to block beta, I just couldn't find a better tracker for e10s issues.  If there is another one, please feel free to move it.
Flags: needinfo?(ehsan)
Oh, just found it!

I guess this and bug 1231213 seem like two solutions to the same problem.  I'm not sure if the actor proposed in bug 1231213 gives us anything else that we need, but if we add an actor which is managed by PContent then I suppose this is moot.
Blocks: ServiceWorkers-e10s
No longer blocks: e10s-swbeta
Priority: -- → P5
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1438945
You need to log in before you can comment on or make changes to this bug.