MediaElement Media Source Extensions does not fire canplay before playback has proceeded

RESOLVED DUPLICATE of bug 1194624

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1194624
2 years ago
2 years ago

People

(Reporter: Jon-Carlos Rivera, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
After appending data to a SourceBuffer, `canplay` is never fired by the MediaElement even though there exists enough data to begin decoding frames. The `canplay` event is eventually fired when play is invoked.

Example page showing the problem: http://jsfiddle.net/ayv7q5p4/

Updated

2 years ago
Component: Untriaged → Audio/Video
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1194624
You need to log in before you can comment on or make changes to this bug.