If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[experiment] TP UI Tour does not allow linking to page 2

VERIFIED FIXED

Status

www.mozilla.org
Pages & Content
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: javaun, Assigned: agibson)

Tracking

(Blocks: 1 bug)

Production
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1918520])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
In production, the TP UI tour cannot go directly to step 2.

https://www.mozilla.org/en-US/firefox/45.0a1/tracking-protection/start/?step=2

We're not using this now, but in the near future we'll have a second pathway in to the TP tour -- a doorhanger -- that goes directly to step 2.
(Reporter)

Updated

2 years ago
Whiteboard: [fxprivacy]

Updated

2 years ago
Blocks: 1219353
(Assignee)

Comment 1

2 years ago
We currently only handle step3 conditionally on page load, since going straight to step2 was surplus to requirement for the original tour. We should be able to change this easily enough if required.
(Assignee)

Updated

2 years ago
Whiteboard: [fxprivacy] → [fxprivacy] [kb=1918520]

Updated

2 years ago
Blocks: 1231757
Is there a way I could test this locally with a version that supports linking to step 2?

Apparently the change I need to make is simple:

https://github.com/mozilla/bedrock/blob/master/media/js/firefox/tracking-protection-tour.js#L281

I'll need this for testing the new front-end entry point in bug 1231757.
(Assignee)

Comment 3

2 years ago
You can either install bedrock locally and test, or you can wait until I can take this bug and put it up on a demo server. It shouldn't take long, but I'm on PTO until Friday.
(Assignee)

Updated

2 years ago
Assignee: nobody → agibson
Status: NEW → ASSIGNED
(Assignee)

Comment 4

2 years ago
I've pushed a patch up to demo2:

https://www-demo2.allizom.org/en-US/firefox/45.0a1/tracking-protection/start/

Please note for the tour to work on the demo2 server, you will need to whitelist https://www-demo2.allizom.org for UITour:

http://bedrock.readthedocs.org/en/latest/uitour.html#local-development

If you also need to set the TP tour button URL see:

http://bedrock.readthedocs.org/en/latest/uitour.html#tracking-protection-uitour

Paolo, please confirm that this patch does what you need, and I will get it reviewed and merged/pushed to production. Thanks
Flags: needinfo?(paolo.mozmail)
Thanks for the quick update and the setup information! Works perfectly.

Just a heads up that we may need to use a version of the tour that closes the tab at the end instead of restarting it. Not sure whether there is a UITour API to do that, though. We'll file new bugs anyways.
Flags: needinfo?(paolo.mozmail)
(Assignee)

Comment 6

2 years ago
(In reply to :Paolo Amadini from comment #5)
> Thanks for the quick update and the setup information! Works perfectly.
> 
> Just a heads up that we may need to use a version of the tour that closes
> the tab at the end instead of restarting it. Not sure whether there is a
> UITour API to do that, though. We'll file new bugs anyways.

Great, thanks. I'll open a PR for review.

Fwiw, I don't think we currently have the ability to close a tab via clicking an element on the page. There's no UITour function to do so as it stands, and window.close() only works for windows that are opened via a script e.g. window.open().
(Assignee)

Comment 7

2 years ago
Created attachment 8700009 [details] [review]
GitHub pull request

Updated

2 years ago
Summary: TP UI Tour does not allow linking to page 2 → [experiment] TP UI Tour does not allow linking to page 2

Comment 8

2 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/a58828f365289c939257c8fc2dbbf1f55b5acb6e
[fix bug 1231785] TP UI Tour does not allow linking to step 2

https://github.com/mozilla/bedrock/commit/6832f36ad00656da06fb6d23824532d100fc4415
Merge pull request #3676 from mozilla/bug-1231785-tp-tour-link-step-2

[fix bug 1231785] TP UI Tour does not allow linking to step 2

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(In reply to Javaun Moradi [:javaun] from comment #0)
> In production, the TP UI tour cannot go directly to step 2.> 
> https://www.mozilla.org/en-US/firefox/45.0a1/tracking-protection/start/
> ?step=2
How exactly can this be tested? While trying to reproduce, Step 2 was displayed fine by simply opening the above link in Nightly 2015-12-10.
Flags: needinfo?(agibson)
(Assignee)

Comment 10

2 years ago
(In reply to Paul Silaghi, QA [:pauly] from comment #9)
> (In reply to Javaun Moradi [:javaun] from comment #0)
> > In production, the TP UI tour cannot go directly to step 2.> 
> > https://www.mozilla.org/en-US/firefox/45.0a1/tracking-protection/start/
> > ?step=2
> How exactly can this be tested? While trying to reproduce, Step 2 was
> displayed fine by simply opening the above link in Nightly 2015-12-10.

This bug has already been fixed and deployed to production. Looks like you have just verified it is working? :)
Flags: needinfo?(agibson)
I guess so. Thanks.
Status: RESOLVED → VERIFIED

Updated

2 years ago
Priority: -- → P1

Updated

2 years ago
Priority: P1 → --

Updated

2 years ago
Priority: -- → P1

Updated

2 years ago
Whiteboard: [fxprivacy] [kb=1918520] → [kb=1918520]
You need to log in before you can comment on or make changes to this bug.