After long tapping home button at least three times, Album cover is lost.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
7 months ago

People

(Reporter: zhangmingyu, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-v2.2r unaffected, b2g-master affected)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8697508 [details]
logcat_0714.txt

[1.Description]:
[Aries KK v2.5&master][Flame KK v2.5&master]When we open music app to play a song, then long press home button to enter task manager and press home button to go back homescreen at least three times, the music app will display abnormally.
Found time: 07:14
See attchments: logcat_0714.txt & Aries kk_master.3gp

[2.Testing Steps]: 
1.Open music app.
2. Play a song.
3. Long press home button to enter task manager.
4. Press home button to go back homescreen.
5. Repeat step 3.
6 .Repeat step 4.
7. Repeat step 3 and observe the thumbnail.
[3.Expected Result]: 
7. Album cover should be displayed.

[4.Actual Result]: 
7. Album cover is lost.

[5.Reproduction build]: 
Device: Flame KK v2.2 512mb build(Unaffected)
Build ID               20151210032501
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4381c4b69b9c
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151210.072346
Firmware Date          Thu Dec 10 07:23:57 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.5 512mb build(Affected)
Build ID               20151211000407
Gaia Revision          2eb55a6193b711b4acb5944be3ba8fea138506c8
Gaia Date              2015-12-10 21:18:06
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d0aa054f0eeae855ff0b4d7ef6c984ab96fd1944
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151210.231805
Firmware Date          Thu Dec 10 23:18:14 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK master 512mb build(Affected)
Build ID               20151210150222
Gaia Revision          7e962276913bd4da7ce5fa7540767107ce322c78
Gaia Date              2015-12-09 21:27:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/412e4d7ce98ca4dbc37de133d0f26d7e1a59946f
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151210.183953
Firmware Date          Thu Dec 10 18:40:06 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 build(Affected)
Build ID               20151211001044
Gaia Revision          2eb55a6193b711b4acb5944be3ba8fea138506c8
Gaia Date              2015-12-10 21:18:06
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d0aa054f0eeae855ff0b4d7ef6c984ab96fd1944
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151210.232018
Firmware Date          Thu Dec 10 23:20:26 UTC 2015
Bootloader             s1

Device: Aries KK master  build(Affected)
Build ID               20151210120926
Gaia Revision          7e962276913bd4da7ce5fa7540767107ce322c78
Gaia Date              2015-12-09 21:27:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/412e4d7ce98ca4dbc37de133d0f26d7e1a59946f
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151210.112747
Firmware Date          Thu Dec 10 11:27:55 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free test
(Reporter)

Comment 1

3 years ago
Created attachment 8697510 [details]
Aries kk_master.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.2r: --- → unaffected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Whiteboard: [systemsfe]
Keywords: regression
Keywords: regressionwindow-wanted
QA Contact: sleedavid
B2G Inbound Regression Window: 

May have been caused by changes made by Bug 1210188. 

Last working

Device: Flame 2.5
BuildID: 20150930193926
Gaia: 06eea0e94e0b2f708e7a208e010b82bd4c94a33e
Gecko: e8e1efed6b72af711b978ba897006ca62d58dd3c
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken

Device: Flame 2.5
BuildID: 20150930202827
Gaia: 61701c2cbe42128d234c6b4bb4e388a76e331c72
Gecko: 496411f2d68d7933c11853605643eb67fff0f501
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Device: Flame 2.5
BuildID: 20150930193926
Gaia: 06eea0e94e0b2f708e7a208e010b82bd4c94a33e
Gecko: 496411f2d68d7933c11853605643eb67fff0f501

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Device: Flame 2.5
BuildID: 20150930202827
Gaia: 61701c2cbe42128d234c6b4bb4e388a76e331c72
Gecko: e8e1efed6b72af711b978ba897006ca62d58dd3c

PUSHLOG: 
B2G Inbound:

https://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=e8e1efed6b72af711b978ba897006ca62d58dd3c&tochange=496411f2d68d7933c11853605643eb67fff0f501
Blocks: 1210188
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
QA Contact: sleedavid
Justin the changes for but 1210188 seem to have caused this issue.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(jdarcangelo)
gandalf: any ideas why DurationFormat might cause this?
Flags: needinfo?(jdarcangelo) → needinfo?(gandalf)
I have no idea.

I tried to reproduce it and it's very intermittent. I sometimes get it the second time I long-press Home, and sometimes I need 20 long-presses (tested on Nightly from today with Z3).

What's more I can cycle after it happens and everything works again.

No clear errors in the console except of:
E/Music   ( 7021): [JavaScript Error: "uncaught exception: Undefined result for null"]
E/Music   ( 7021): [JavaScript Error: "uncaught exception: Undefined result for null"]
E/Music   ( 7021): [JavaScript Error: "NS_ERROR_ILLEGAL_VALUE: "]

which happens usually before this bug.

Given the intermittent nature I'm really not sure what's going on and I doubt it has anything to do with bug 1210188. I'd guess it may be related to the above JS Error, but it may also be task manager bug or even Gecko's graphic bug.
Flags: needinfo?(gandalf)

Comment 7

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.