[Email]Can switch device to landscape mode after user locks and then unlocks the screen at inputting Email account view.

RESOLVED DUPLICATE of bug 1226454

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1226454
2 years ago
2 years ago

People

(Reporter: zouyi(Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8697509 [details]
logcat_1606.txt

[1.Description]:
[Aires v2.5&master][Flame v2.5&master]Go to Email account inputting view, lock and unlock device, device can be switched to landscape mode. On v2.5, when user slides up and down at password view, it is shown unstably with flash.
See attchments: locat_1606.txt&Aries_kk v2.5.3gp
Found time: 16:06
 
[2.Testing Steps]: 
1. Launch Email app.
2. Input name and Email address, tap next.
3. Tap power button twice.
4. Rotate device to landscape.
5. Tap next, slide up and down the view.

[3.Expected Result]: 
4. Should not be switched to landscape.
5. The view shown normally.

[4.Actual Result]: 
4. Can switch device to landscape.
5. On v2.5, The view is shown unstably with flash.

[5.Reproduction build]: 
Device: Flame KK v2.5 512mb(Affected) 
Build ID               20151211000407
Gaia Revision          2eb55a6193b711b4acb5944be3ba8fea138506c8
Gaia Date              2015-12-10 21:18:06
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d0aa054f0eeae855ff0b4d7ef6c984ab96fd1944
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151210.231805
Firmware Date          Thu Dec 10 23:18:14 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK master 512mb(Affected)
Build ID               20151210150222
Gaia Revision          7e962276913bd4da7ce5fa7540767107ce322c78
Gaia Date              2015-12-09 21:27:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/412e4d7ce98ca4dbc37de133d0f26d7e1a59946f
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151210.183953
Firmware Date          Thu Dec 10 18:40:06 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5(Affected)
Build ID               20151211001044
Gaia Revision          2eb55a6193b711b4acb5944be3ba8fea138506c8
Gaia Date              2015-12-10 21:18:06
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d0aa054f0eeae855ff0b4d7ef6c984ab96fd1944
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151210.232018
Firmware Date          Thu Dec 10 23:20:26 UTC 2015
Bootloader             s1

Device: Aries KK master(Affected) 
Build ID               20151210120926
Gaia Revision          7e962276913bd4da7ce5fa7540767107ce322c78
Gaia Date              2015-12-09 21:27:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/412e4d7ce98ca4dbc37de133d0f26d7e1a59946f
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151210.112747
Firmware Date          Thu Dec 10 11:27:55 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

2 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
(Reporter)

Comment 1

2 years ago
Created attachment 8697511 [details]
Aries_kk v2.5.3gp
Since email's manifest.webapp's "orientation": "default" value has not changed in quite a while, and that the email app does not rotate before the lock switch change, I suspect a deeper issue outside of email is in play. Moving it to the system app since they likely have a better idea on how to route the issue to the core component.

Some notes about these STR: The email account setup is for a gmail account, which means the view that is shown that has the rotation issue is one that includes a mozbrowser iframe that is showing the Google OAuth sign-in flow.
Component: Gaia::E-Mail → Gaia::System
We had a similar issue in bug 1226454, with the window being allowed to rotate when it should be orientation locked. I think this is a dupe - please re-open if you disagree.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226454
You need to log in before you can comment on or make changes to this bug.