If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

REST API doesn't seem to work on Windows (IIS)

RESOLVED DUPLICATE of bug 1200620

Status

()

Bugzilla
WebService
RESOLVED DUPLICATE of bug 1200620
2 years ago
2 years ago

People

(Reporter: Kevin Turner, Unassigned)

Tracking

5.0.1

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.73 Safari/537.36

Steps to reproduce:

Installed 5.0.1 on windows with correct IIS settings including the recommended rewrite rule.

Tested with http://<server>/rest/version

In my case, $cgi->path_info returns "/bugzilla/rest.cgi/version" instead of "/version" so it fails all the regexp tests.

I have looked at bugs #1200604 and #1200620 and they seem to indicate that it is fixed in the "cgi module", but I still get this issue even when I tried it with version 5.1.0.

Where do I obtain the correct cgi module as recommended in #1200620?


Actual results:

Returned 

{
   "code" : 32614,
   "documentation" : "http://www.bugzilla.org/docs/tip/en/html/api/",
   "error" : true,
   "message" : "A REST API resource was not found for 'GET /bugzilla/rest.cgi/version'."
}



Expected results:

Should return the version number
(Reporter)

Comment 1

2 years ago
I should add that I am using ActivePerl v5.20.2, so the cgi module should be up to date.

An alternative would be to use Strawberry Perl but I cannot get Bugzilla to work with that at all yet.

Perhaps there is a workaround I can use in the Bugzilla code if the cgi module is not readily available to Windows users?

Comment 2

2 years ago
(In reply to Kevin Turner from comment #1)
> Perhaps there is a workaround I can use in the Bugzilla code if the cgi
> module is not readily available to Windows users?

The latest CGI module is available on Windows, see https://code.activestate.com/ppm/CGI/.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1200620
(Reporter)

Comment 3

2 years ago
Seems OK with Strawberry Perl also
You need to log in before you can comment on or make changes to this bug.