The Contents hyperlinks change the page zoom value

RESOLVED INVALID

Status

()

Firefox
PDF Viewer
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected, firefox44 affected, firefox45 affected, firefox-esr38 affected)

Details

Reproducible on: Firefox 45.0a1, Firefox 44.0a2, Firefox 43RC and Firefox 38.5.0 ESR across all platforms


STR
1.Launch Firefox with a clean profile.
2.Navigate to http://cp.literature.agilent.com/litweb/pdf/5989-8139EN.pdf#page=2
3.Choose a predefined zoom value from the drop down list.
4.Click on a hyperlink from Table of Contents.
5.Check the zoom value.


ER
The zoom value remains the same.

AR
The zoom value changes in a decimal number.
It modifies depending on the window size.
See screenshots: http://i.imgur.com/d2fdubX.png
                 http://i.imgur.com/xkWqtk0.png


Additional notes:
- Reproducible on: Firefox 45.0a1 (2015-12-11), Firefox 44.0a2 (2015-12-11), Firefox 43 RC (20151208100201) and Firefox 38.5.0 ESR (20151210074901) under Ubuntu 14.04 32-bit, Windows 10 32-bit and Mac OS X 10.11.1
If you open that PDF file with e.g. Adobe Reader, you will notice that the behaviour is the same as in PDF.js, i.e. the zoom level changes when clicking on links.
In this case, the PDF file *itself* actually specifies that the zoom level should change when those links are clicked.

Please note that hyperlinks on the web are slightly different than the concept of destinations used in PDF files, please refer to the specification: http://www.adobe.com/content/dam/Adobe/en/devnet/acrobat/pdfs/PDF32000_2008.pdf#G11.2063217.

Since PDF.js actually does what the specification says here, in my opinion this bug is thus invalid.
Confirmed same behavior with Adobe Reader. Resolving as invalid per comment 1.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.