highlighting of saved passwords when deleting behaves unexpectedly

RESOLVED DUPLICATE of bug 1081779

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1081779
2 years ago
2 years ago

People

(Reporter: u314746, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

opened saved password dialog
selected a password entry line (say the fifth one)
deleted password entry line



Actual results:

after deleting the fifth line, it appears that the entries redrew themselves and the password that was highlighted was no longer the fifth one but the first one was highlighted.


Expected results:

The usual behavior when using listboxes is that the highlighted entry stays where it is.  I had to delete entries 5-7.  I usually would just press the delete button three times but in this case, I had to (highlight, delete)*3 instead of just pressing the delete button.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081779
You need to log in before you can comment on or make changes to this bug.