Closed Bug 1231957 (devtools-eslint) Opened 5 years ago Closed 8 months ago

[meta] Fix devtools files so that they can be removed from .eslintignore

Categories

(DevTools :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: miker, Unassigned, Mentored)

References

(Blocks 1 open bug)

Details

(Keywords: meta)

We need to go through .eslintignore and fix all eslint warnings and errors in devtools files.
Whiteboard: [good-first-bug lang=js]
I'd argue that this should be a meta bug and that we create smaller bugs for each file we clean up.
I also think we should wait for bug 1229106 to be fixed first. There's no sense in removing files from .eslintignore until eslint runs automatically somewhere, otherwise new errors will creep in without us realizing.
Duplicate of this bug: 1230070
Depends on: 1232731
Depends on: 1229859
Blocks: eslint
Depends on: 1240063
Keywords: meta
Summary: Fix devtools files so that they can be removed from .eslintignore → [meta] Fix devtools files so that they can be removed from .eslintignore
Removing GFB here, since it should likely be handled in the individual children if desired.
Whiteboard: [good-first-bug lang=js]
Depends on: 1231963
Depends on: 1240183
Depends on: 1248563
Alias: devtools-eslint
Depends on: 1251728
Depends on: 1252803
Depends on: 1252807
Depends on: 1255799
Depends on: 1255827
Depends on: 1256948
Depends on: 1267378
Depends on: 1268974
Depends on: 1270994
Depends on: 1271084
Duplicate of this bug: 1098222
Depends on: 1098222
Depends on: 1273653
Depends on: 1250205
Depends on: 1274964
Depends on: 1275096
Depends on: 1275637
Depends on: 1316700
Depends on: 1316723
Depends on: 1316809
Depends on: 1317069
Depends on: 1321839
Depends on: 1322085
No longer depends on: 1256948
Depends on: 1325191
Depends on: 1325213
Depends on: 1325987
Depends on: 1325988
Depends on: 1325989
Depends on: 1326331
Depends on: 1326334
Depends on: 1326408
Depends on: 1326410
Depends on: 1326412
Depends on: 1328929
Depends on: dt-eslint-rules
Depends on: 1331802
Depends on: 1344286
Blocks: 1357557
Depends on: 1451659
Depends on: 1452575
Depends on: 1453383
Depends on: 1458277
Product: Firefox → DevTools
No longer depends on: 1275096
No longer depends on: 1098222
Depends on: 1580250
Depends on: 1582658
Depends on: 1589333
Depends on: 1589334
No longer depends on: dt-eslint-rules

As far as I can tell, we've now removed all the devtools entries from .eslintignore that we can. The remaining items are generated code, sourcemaps, intentionally broken code etc.

The only part remaining is the web replay code which is being removed in bug 1609815.

However, I think we can mark this one as fixed now and track that there.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.