Use .svg for the Windows twisties after bug 1191230

RESOLVED FIXED in Thunderbird 46.0

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 46.0
All
Windows
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird44 unaffected, thunderbird45 fixed, thunderbird46 fixed)

Details

Attachments

(1 attachment)

Bug 1191230 updates the tree twisties to svg images. To not break our use of the twisties we need to follow on Windows to use the svg images.
This simply changes from png to svg. On chat files I added %ifdef XP_WIN to use the svg files.

Bug 1191230 is now checkin-needed and lands hopefully until Monday.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8697640 - Flags: review?(clokep)
Comment on attachment 8697640 [details] [diff] [review]
twisty.svg.patch

Review of attachment 8697640 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/components/im/themes/chat.css
@@ +530,5 @@
>    width: 9px; /* The image's width is 9 pixels */
>    height: 9px;
>    -moz-margin-end: 3px;
>    -moz-margin-start: 3px;
> +  background: url("chrome://global/skin/tree/twisty.svg#open") no-repeat center;

Doesn't this and im/themes/blist.css also apply to all operating systems? Why are they not ifdefed?
No, because the full block is this:

/* from instantbird/themes/blist.css */
%ifdef XP_WIN
imgroup .twisty {
  padding-top: 1px;
  width: 9px; /* The image's width is 9 pixels */
  height: 9px;
  -moz-margin-end: 3px;
  -moz-margin-start: 3px;
  background: url("chrome://global/skin/tree/twisty.svg#open") no-repeat center;
}

imgroup[closed] .twisty {
  background: url("chrome://global/skin/tree/twisty.svg#clsd") no-repeat center;
}
%else
Comment on attachment 8697640 [details] [diff] [review]
twisty.svg.patch

Review of attachment 8697640 [details] [diff] [review]:
-----------------------------------------------------------------

Ahh, of course! Thanks for the explanation!
Attachment #8697640 - Flags: review?(clokep) → review+
http://hg.mozilla.org/comm-central/rev/f0294b557494
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 46.0
Comment on attachment 8697640 [details] [diff] [review]
twisty.svg.patch

[Approval Request Comment]
Regression caused by (bug #): 1191230, which also has approval for aurora requested
User impact if declined: no visible twisties
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): very low, only CSS changes
Attachment #8697640 - Flags: approval-comm-aurora?
Bug 1191230 landed now on aurora. This bug should also land on aurora to show all twisties.
Attachment #8697640 - Flags: approval-comm-aurora? → approval-comm-aurora+
Depends on: 1236216
Blocks: 1236216
No longer depends on: 1236216
Keywords: checkin-needed
Whiteboard: [checkin-needed comm-aurora]
Aurora:
https://hg.mozilla.org/releases/comm-aurora/rev/7b974b565a71
Keywords: checkin-needed
Whiteboard: [checkin-needed comm-aurora]
You need to log in before you can comment on or make changes to this bug.