Home Screen can be stopped between panels if the user long presses an app to enter edit mode with a second finger.

RESOLVED DUPLICATE of bug 1232064

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1232064
3 years ago
2 years ago

People

(Reporter: Marty, Assigned: cwiiis)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master affected)

Details

(Whiteboard: [2.6-Daily-Testing][Spark][systemsfe], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8697715 [details]
logcat_Homescreen-two-finger-pan.txt

Description:
If the user is panning between the panels, and then long-presses an app with a second finger, the device will stop between the two panels when it enters edit mode.

Note: This issue is separate from the issue described in bug 1190469. The homescreen will not stick when locking the device, and will not stick unless the user has at least one finger long pressing an app.

Repro Steps:
1) Update a Aries to 20151211115227
2) At the homescreen, pan halfway between the two homescreen panels.
3) User a second finger to long-press an app.

Actual:
Homescreen will stop between the two panels after long pressing an app with a second finger.

Expected:
Homescreen will not stick between panels after long pressing an app with a second finger.

Environmental Variables:
Device: Aries 2.6
Build ID: 20151211115227
Gaia: d886e152b42e557db612470d3417fe2947cbdeee
Gecko: 754b4805a65cab4f3aca99899227acc44ba4fb20
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 9/10
See attached: Video (URL), Logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on the latest Flame Nightly 2.6 and 2.5 builds.
Homescreen will stop between the two panels after long pressing an app with a second finger.

Environmental Variables:
Device: FlameKK 2.6 (512MB)
BuildID: 20151211030233
Gaia: d886e152b42e557db612470d3417fe2947cbdeee
Gecko: 754b4805a65cab4f3aca99899227acc44ba4fb20
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: FlameKK 2.5 (512MB)
BuildID: 20151211164817
Gaia: 062e0fa48c1b5d5156f6911a5a4519128fac3231
Gecko: ded0306e0d78528cdcb237c8b05543390f10ec96
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

*****************************************

The New Homescreen is not implemented in the 2.2 branch.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Chris can you take a look at this?  Similar to bug 1190469 but still occurs even though that is fixed.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(chrislord.net)
(Assignee)

Comment 3

3 years ago
Passing needinfo to kats, this is a core apz issue. Kats, if you have ideas why this is happening and you have higher priority things to fix, do post as much detail here as you can and hopefully I'll have some free time to get to it in Q1.
Component: Gaia::Homescreen → Panning and Zooming
Flags: needinfo?(chrislord.net) → needinfo?(bugmail.mozilla)
Product: Firefox OS → Core
(Assignee)

Comment 4

3 years ago
Actually, sorry for bug spam, I think I know what this is and it's nothing to do with apz :)

Assigning to myself to deal with after PTO.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Component: Panning and Zooming → Gaia::Homescreen
Flags: needinfo?(bugmail.mozilla)
Product: Core → Firefox OS
(Assignee)

Updated

3 years ago
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][systemsfe]
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1232064
You need to log in before you can comment on or make changes to this bug.