Closed Bug 1232070 Opened 7 years ago Closed 7 years ago

Test execution of tests in docker comes to a halt

Categories

(Testing :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1221661

People

(Reporter: armenzg, Unassigned)

References

Details

Attachments

(1 file)

I have attached a screenshot which shows the browser with a plugin crash.
It stops there for a minute to three and it suddently resumes.

I've seen it happen when running this (which starts a browser-chrome run):
 docker run --device=/dev/video1:/dev/video1 -p=5900:5900 -ti --rm djmitche/rundesktop:latest

I wish I could have grabbed logs but the instance finishes and exits.
I will tee the output before I head out for my flight.
Is this an expected plugin crash (that is, is this a test of the crash-handling code)?
Component: TaskCluster → General
can we run this test on a local linux instance (not docker) and compare the expected behavior?  This looks to be:
browser/base/content/test/plugins/plugin_crashCommentAndURL.js

in browser chrome it sounds like we are timing out and continuing on base on the little evidence I have.
Why are you using `djmitche/rundesktop:latest`?  That was a one-off hack to play with starting the desktop environment, and I don't think it matches up with what we're running in-tree.  I built it out of a Dockerfile in ~/tmp which I've since deleted, so I can't even tell you what's in it!

Does the same thing happen with the latest desktop-test image?
You based your image on mine so it should be close to desktop-test:
https://bug1223123.bmoattachments.org/attachment.cgi?id=8689674

I would say the same thing should happen on desktop-test (I just can't VNC as-is to see it).
This is a dupe of bug 1221661. That test is hanging because the crash reporter isn't working and it's waiting for a crash report.
I've pushed with ptrace enabled (let's see what the results look like):
https://hg.mozilla.org/try/rev/c3cb854e7fa0
That push occurred before we enabled the feature on desktop-test, so ignore it.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1221661
You need to log in before you can comment on or make changes to this bug.