Certain Hebrew diacritics appear in wrong position

RESOLVED DUPLICATE of bug 60546

Status

()

defect
RESOLVED DUPLICATE of bug 60546
18 years ago
11 years ago

People

(Reporter: xslf, Assigned: mkaply)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.8+) Gecko/20020201
BuildID:    2002020103

Hebrew diacritics appear in wrong positions. It looks like this heppends mainly
when there is more then one diacritic on each character

Reproducible: Always
Steps to Reproduce:
1. go to the above URLs
2. read the text
3. notice the diacritic positioning

Actual Results:  when there is more then one diacritic per chacharcter, the
positiong is incorrect

Expected Results:  should look correct

Comment 1

17 years ago
Is this a dupe of bug 60546?
Reporter

Comment 2

17 years ago
*** Bug 150151 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
If I view HTML "c¸" I see cedilla to the right of c, not under it. Perhaps
this is geneneric problem with diatrics, 
and not specific to BiDi

Comment 4

17 years ago
s/diatrics/diacritics/ of course.  I saw it with Mozilla 1.0 on Linux
Reporter

Comment 5

17 years ago
I see this now also on Moz 1.0 on windows 98.
Changing to all.
OS: Mac System 9.x → All
Hardware: Macintosh → All
Reporter

Updated

17 years ago

Comment 7

17 years ago
Your screenshot indicates that this bug is a duplicate of Bug 60546.  
Diacritics appear in wrong position even if only one diacritic is added to a 
base character.

AbiWord also suffers from this bug:
http://bugzilla.abisource.com/show_bug.cgi?id=3768

*** This bug has been marked as a duplicate of 60546 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.