Adding a button to clear all recently opened applications.

RESOLVED DUPLICATE of bug 1123148

Status

RESOLVED DUPLICATE of bug 1123148
3 years ago
3 years ago

People

(Reporter: damarla.sumanth, Unassigned)

Tracking

({feature, foxfood, uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
>> Feature Request Summary:
Adding a button to clear all recently opened applications.

>> Description of feature, or problem to be solved
Today, there is no way for the user to quickly close all the recently opened applications. He needs to close it one by one which could be a bit uncomfortable if there are too many opened applications. I am using Firefox OS in Sony Xperia Z3C and I don't see a button (say "clear all") when I am trying to close multiple applications. Hence, Including a button for closing all the opened applications similar to "clear all" feature to clear all the notifications in the notification tray can be use really useful.
Status: UNCONFIRMED → NEW
Component: Gaia::System → Gaia::System::Task Manager
Ever confirmed: true
Flags: needinfo?(firefoxos-ux-bugzilla)
Whiteboard: [systemsfe]
This will require some design work - adding UIwanted tag.

Thanks for pinging the UX team!
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: uiwanted
(Reporter)

Comment 2

3 years ago
Hello

Can I have update on this bug..

Thanks!
Flags: needinfo?(tshakespeare)
Unfortunately, we are still short staffed and do not have the bandwidth to tackle this for 2.6. If there were a design contributor, we could work with them. Another alternative would be to create an add-on.

I know it's not the answer you're hoping for, but we aren't able to help out at the moment. It's in our backlog for us to tackle when we can.

Thanks!
Flags: needinfo?(tshakespeare)

Comment 4

3 years ago
You already have this feature with add-on Kill All
(Reporter)

Comment 5

3 years ago
Can't we just add this feature as an in-built feature rather than a user need to search for appropriate add-on and install it?? This kind of feature needs to be in-built. Many other mobile OS have this as a core feature(In-built). The user expect this feature come along with the OS itself.
Flags: needinfo?(mihaibn)

Comment 6

3 years ago
This is the power of the add-ons. It gives you the functionality you want in a quick way. So as far as the bug goes, from my side the issue is fixed. You have a means to get this functionality.

There is a complete other discussion about having this by default in the OS and I'm not in a position to talk about this.

Did you tried the add-on I mentioned?
Flags: needinfo?(mihaibn)

Comment 7

3 years ago
(In reply to damarla.sumanth from comment #5)
> Can't we just add this feature as an in-built feature rather than a user
> need to search for appropriate add-on and install it?? This kind of feature
> needs to be in-built. Many other mobile OS have this as a core
> feature(In-built). The user expect this feature come along with the OS
> itself.

and yes, I do expect people to use addons, just like people use Extensions with the Firefox browser. This is the beauty of the add-on system. It gives you power and flexibility!
(Reporter)

Comment 8

3 years ago
(In reply to Mihai Barbat from comment #7)
> (In reply to damarla.sumanth from comment #5)
> > Can't we just add this feature as an in-built feature rather than a user
> > need to search for appropriate add-on and install it?? This kind of feature
> > needs to be in-built. Many other mobile OS have this as a core
> > feature(In-built). The user expect this feature come along with the OS
> > itself.
> 
> and yes, I do expect people to use addons, just like people use Extensions
> with the Firefox browser. This is the beauty of the add-on system. It gives
> you power and flexibility!

I love using the add-one and know its pros but I would like to add that this is one feature which needs to be by default in the OS.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123148
You need to log in before you can comment on or make changes to this bug.