Use GitHub instead of SVN as localization source

RESOLVED FIXED

Status

()

Firefox for iOS
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: flod, Assigned: flod)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

2 years ago
We need to update scripts to pick up strings from GitHub instead of SVN.
(Assignee)

Updated

2 years ago
Blocks: 1232241
No longer depends on: 1232241
(Assignee)

Comment 1

2 years ago
Looks like I lost track of how things work
https://github.com/mozilla/firefox-ios/commit/074677e714a7a4991c74ceafc568fcf9b15af67f

Removed the /scripts folder completely and moved it to
https://github.com/mozilla/firefox-ios-build-tools
(Assignee)

Comment 2

2 years ago
Created attachment 8697960 [details] [review]
Pull request on Github

This should be good for review, but we need to make sure we don't have delays on the tools' side before merging.
Duplicate of this bug: 1232320
Comment on attachment 8697960 [details] [review]
Pull request on Github

Emily can you merge this if it looks good?
Attachment #8697960 - Flags: review?(etoop)
PR merged. Not closing bug as there is a small amount of work to do to get things working with fastlane
Attachment #8697960 - Flags: review?(etoop) → review+
Pushed some small fixes that I discovered while running the export-locales script:

https://github.com/mozilla/firefox-ios-build-tools/commit/a299e23bb1fcdfb6f8fed16609f2cdf9bf804e2e
(Assignee)

Comment 7

2 years ago
Created attachment 8703250 [details] [review]
Improve workflow in export-locales.sh

I'm making a few assumptions based on the existing paths (didn't find any documentation): 
* The firefox-ios-build-tools folder is placed at the same level as firefox-ios
* The script is run from the main project folder as ../firefox-ios-build-tools/scripts/export-locales.sh

Improvements:
* Reuse existing virtualenv by default, since setting it up takes forever. Run with 'clean' parameter to set up a new virtualenv
* Create a branch in the l10n repository, commit file individually. I've left the 'git push' command commented out, but it could be changed.

Note: the main repository should really have firefox-ios-l10n and export-locales-env in .gitignore
Attachment #8703250 - Flags: review?(sarentz)
Created attachment 8703585 [details] [review]
Don't commit firefox-ios-l10-n repo for fastlane purposes
Attachment #8703585 - Flags: review?(sarentz)
Comment on attachment 8703585 [details] [review]
Don't commit firefox-ios-l10-n repo for fastlane purposes

LGTM
Attachment #8703585 - Flags: review?(sarentz) → review+
Comment on attachment 8703250 [details] [review]
Improve workflow in export-locales.sh

LGTM Please test it well
Comment on attachment 8703250 [details] [review]
Improve workflow in export-locales.sh

LGTM Please test it well
Attachment #8703250 - Flags: review?(sarentz) → review+
(Assignee)

Comment 12

2 years ago
NI for Stefan to merge the PR. Once merged we can close this bug for good.
Flags: needinfo?(sarentz)
(Assignee)

Comment 13

2 years ago
Thanks Emily for the merge, we can close this bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(sarentz)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.