Closed Bug 1232289 Opened 4 years ago Closed 4 years ago

Deep tree of call stacks ends up with hidden overflow to right of toolbox, can't see the function names

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P3)

defect

Tracking

(firefox48 fixed)

RESOLVED FIXED
Firefox 48
Tracking Status
firefox48 --- fixed

People

(Reporter: bgrins, Assigned: vporof)

References

Details

Attachments

(3 files, 1 obsolete file)

STR:
Import attached profile into the performance tool
Switch to call stack view
Hold right arrow to keep expanding the tree

Expected:
No matter how deep the stack is I can still see the function calls (possibly by scrolling to the right)

Actual:
Eventually the data disappears off the page
Screenshot of the issue
Triaging. Filter on ADRENOCORTICOTROPIC (yes).
Priority: -- → P3
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #8732616 - Flags: review?(jsantell)
Attached patch v2Splinter Review
Fixed tests.
Attachment #8732616 - Attachment is obsolete: true
Attachment #8732616 - Flags: review?(jsantell)
Attachment #8732619 - Flags: review?(jsantell)
Duplicate of this bug: 1243454
Attachment #8732619 - Flags: review?(jsantell) → review+
https://hg.mozilla.org/integration/fx-team/rev/51452ac19164edb8242bb4e8f56ba2548a69f765
Bug 1232289 - Deep tree of call stacks ends up with hidden overflow to right of toolbox, can't see the function names, r-jsantell
https://hg.mozilla.org/mozilla-central/rev/51452ac19164
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.