Closed Bug 1232328 Opened 5 years ago Closed 4 years ago

HAR Viewer redeclares functions; not ES6 compatible

Categories

(Core :: JavaScript Engine, defect)

45 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox44 --- unaffected
firefox45 - affected

People

(Reporter: mcmanus, Assigned: nihsanullah)

References

Details

(Keywords: regression)

http://www.softwareishard.com/har/viewer/ renders as blank page in nightly 45 linux x64 Built from https://hg.mozilla.org/mozilla-central/rev/99137d6d4061f408ae0869122649d8bdf489cc30

looks fine on current 44
Reduce:
with ({}) {
    function Pie() {}
    var Pie = "test";
}
For now, block-scoped functions and Annex B semantics have been backed out for breaking the web (Google Inbox being most prominent): https://hg.mozilla.org/integration/mozilla-inbound/rev/d2bec6ed7b30

Keeping NI open so I can investigate for when we re-land.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Actually let me reopen and NI Jan, this is a bug in his code.

Jan, |function Pie() {}| and |var Pie = ...| in HAR Viewer in webapp/scripts/pageState.js break in ES6 because functions are block-scoped. Could you fix?

I would've filed an issue on Google Code but there was some warning about how the project is archived and read-only.
Status: RESOLVED → REOPENED
Flags: needinfo?(shu) → needinfo?(odvarko)
Resolution: FIXED → ---
Summary: http://www.softwareishard.com/har/viewer/ renders as blank page → HAR Viewer redeclares functions; not ES6 compatible
Thanks for the note!

The project is on github.com

Here is the related issue + patch:
https://github.com/janodvarko/harviewer/issues/50

How can I test this?
If I understand the breaking changes have been backed out?

Honza
Flags: needinfo?(odvarko) → needinfo?(shu)
Ah, forgot to note, the patch is in the repo (master), but not yet released (online) on the site.

Honza
We can sit on it for now. I'll try to reland the breaking changes in a week or two when Inbox gets fixed. Then we can verify the patch fixes the problem.
Flags: needinfo?(shu)
Not tracking for 45 as we moved this change to 46.
inbox appears to be fixed, can we proceed?
Flags: needinfo?(nihsanullah)
Google Inbox has been fixed and functions-in-block has relanded. If :Honza has merged his tip fix we can close.
Thanks Shu. Honza let us know how it goes.
Flags: needinfo?(nihsanullah) → needinfo?(odvarko)
Assignee: nobody → nihsanullah
Yes, fixed and the online version is updated
http://janodvarko.cz/har/viewer/

Honza
Flags: needinfo?(odvarko)
Status: REOPENED → RESOLVED
Closed: 5 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.