text is rendered with lateral slippage

RESOLVED DUPLICATE of bug 97861

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 97861
17 years ago
17 years ago

People

(Reporter: David W Noon, Assigned: Marc Attinasi)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:0.9.7) Gecko/20011222
BuildID:    2001122123

When a run of text requires that the canvas be scrolled, quite often this
results in a line of text that had been at the boundary to be rendered with the
text slipped slightly to the right. The result is that the pixels for the parts
of the text that were visible before scrolling are not vertically aligned with
those that were hidden before scrolling; this gives the line a "rippled"
appearance, as if a fold had been placed where the boundary had been.

This effect occurs with many Web sites, not just the URL above.

This effect does not occur with Netscape 4.x for OS/2, nor does it occur with
Netscape 6.x for LINUX. It seems peculiar to the OS/2 version of Mozilla.

Reproducible: Sometimes
Steps to Reproduce:
1. Connect to any URL that will supply you with a multi-screen volume of text.

2. Note the text that straddles the lower boundary of the canvas. If it is not
the upper part of a line, scroll with the scrollbar until it is.

3. Scroll the text down. The line that had been partially rendered before is
quite frequently show with the [newly rendered] lower part of the line slipped
one or two pixels to the right of the upper part. If it does not occur, keep
scrolling and pausing until it does.

Actual Results:  The line of text that had been at the bottom of the display
area is renderd in two parts: the upper part correctly located in the canvas;
the lower part slipped a couple of pixels to the right.

If I scroll the problem text completely off the screen and then scroll it back
into the displayable area, it is rendered correctly.

Expected Results:  The text should be rendered smoothly.

OS/2 Warp 4 fixpak 12.
Matrox G400 video adapter, using Matrox's native OS/2 video drivers.

Comment 1

17 years ago
WFM, win98SE, 2002013003

Comment 2

17 years ago
->layout
Assignee: trudelle → attinasi
Component: XP Apps → Layout
QA Contact: sairuh → petersen
dwnoon: what are your fonts set to in preferences?
dwnoon:  Also, can you please try this with the nightly build?  Thanks.
Based on the private conversation I have had with David, this issue seems to be
causes by the "60" patch for nsTransform2D (bug 97861).  This has been checked
into the milestones, but not into the trunk;  David and I only saw this issue in
the milestones.  

*** This bug has been marked as a duplicate of 97861 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.