Closed Bug 1232359 Opened 6 years ago Closed 6 years ago

Calling Mozilla conference call line tones are not dialing

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.5 unaffected, b2g-master verified)

VERIFIED DUPLICATE of bug 1232363
Tracking Status
b2g-v2.5 --- unaffected
b2g-master --- verified

People

(Reporter: vbelonenko, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [2.6-Daily-Testing][Spark])

Attachments

(2 files)

Description:
When calling Mozilla conference line dialing extension tones, it does not function. User cannot hear key pad dialing.

Repro Steps:
1) Update a Aries to 20151214121335
2) Dial # 1 650 903 0800
3) Then type extension 92
4) Observe that you can't hear extension tones dialing in when pressing in the key pad.

Actual:
Extension tones would not dial after dialing a number

Expected:
User should be able to hear tones sounds dialing from keypad

Environmental Variables:
Device: Aries Master 2.6 kk full flash
Build ID: 20151214121335
Gaia: ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gecko: 99137d6d4061f408ae0869122649d8bdf489cc30
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 3/3
See attached: logcat
Attached file logcat
Link to failed smoke test case: https://moztrap.mozilla.org/manage/case/6076/
This issue does not occurs on Flame 2.6 and Flame 2.5
Result: User was able able to hear tones sounds dialing from keypad

Environmental Variables:
Device: Flame 2.6 kk full flash
Build ID: 20151214120733
Gaia: ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gecko: 99137d6d4061f408ae0869122649d8bdf489cc30
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.5 kk full flash
BuildID: 20151214083757
Gaia: 062e0fa48c1b5d5156f6911a5a4519128fac3231
Gecko: d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regression
QA Contact: jthomas
This occurs on Flame 2.6 kk full flash
QA Contact: jthomas
Extension toners are not dialing for back end system, it does not connect.
Major smoketest blocker that is a regression. Let's get a window here.
blocking-b2g: --- → 2.6?
QA Contact: jthomas
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: smoketest
mozilla inbound regression window:

Last Working
Device: Flame 2.6
BuildID: 20151211074133
Gaia: d886e152b42e557db612470d3417fe2947cbdeee
Gecko: ee132b90ad4b11b03c4dcc5b21bc636ef11bbe66
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Device: Flame 2.6
BuildID: 20151211081830
Gaia: d886e152b42e557db612470d3417fe2947cbdeee
Gecko: eb3d458624eb3a62e8aebfaed322a63314153d3e
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ee132b90ad4b11b03c4dcc5b21bc636ef11bbe66&tochange=eb3d458624eb3a62e8aebfaed322a63314153d3e

Caused by changes made in Bug 1214148
Blocks: 1214148
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Andrea this smoketest blocker seems to have been caused by the changes for bug 1214148.  Can you please take a look?
Flags: needinfo?(jmercado) → needinfo?(amarchesini)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+][memory-failure]
QA Whiteboard: [QAnalyst-Triage+][memory-failure] → [QAnalyst-Triage+]
Bug 1214148 should not affect dialtones, only audible tones. Are we sure the dialtones are not being played? BTW bug 1227980 is going to change how the callscreen works and might fix this specific use-case so unless an urgent fix is needed we can test that first.
Flags: needinfo?(amarchesini) → needinfo?(alwu)
Same regression window as bug 1232363. Verify me, if it's not the case.
Status: NEW → RESOLVED
blocking-b2g: 2.6? → ---
Closed: 6 years ago
Keywords: smoketestverifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1232363
This bug has been verified as "pass" on the latest build of Flame master and Aries KK master by the STR in comment 0.

Actual results: Calling Mozilla conference call line tones are dialing normally (I called "10010"/"10086").
See attachment: verified_Flame_master.3gp
Reproduce rate: 0/10


Device: Flame master_512mb (Pass)
Build ID               20151215150203
Gaia Revision          ee43a95f2bbe39c5ac8c9fcdec76749a56c02f2e
Gaia Date              2015-12-15 04:30:46
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cb66ffeb6725e8344818e8e2f707ae2eaeb953b4
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151215.184537
Firmware Date          Tue Dec 15 18:45:49 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master (Pass)
Build ID               20151216003129
Gaia Revision          635c79fe14b5c4df919c20e7fc760c7a400ca7cc
Gaia Date              2015-12-15 17:39:35
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/e6463ae7eda2775bc84593bb4a0742940bb87379
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151216.001134
Firmware Date          Wed Dec 16 00:11:42 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
Flags: needinfo?(alwu)
You need to log in before you can comment on or make changes to this bug.