No audible sound coming from Alarm audio channel.

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Marty, Assigned: alwu)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.6?, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing][Spark], URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Description:
There is not audible sound coming from the Alarm channel. Alarms and Timers do not produce any sound. Previewing an alarm sound types does not produce any sound. Changing the Alarm volume in Settings does not produce any sound.

Repro Steps:
1) Update an Aries to 20151214121335
2) Open the Clock app.
3) Configure the Alarm volume to Maximum
4) Set an alarm or timer to go off in 1 minute.

Actual:
Alarm does not make any sound

Expected:
Alarm makes sound at the appropriately configured volume.

Environmental Variables:
Device: Aries 2.6
Build ID: 20151214121335
Gaia: ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gecko: 99137d6d4061f408ae0869122649d8bdf489cc30
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 5/5
Link to failed test case: https://moztrap.mozilla.org/manage/case/2477/
See attached: Video (URL), Logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on the latest Flame 2.6 build.
Alarm does not make any sound

Environmental Variables:
Device: FlameKK 2.6 (512MB)
BuildID: 20151214030209
Gaia: ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gecko: 99137d6d4061f408ae0869122649d8bdf489cc30
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

*******************************************

This issue does NOT occur on the latest Flame 2.5 build.
Alarm makes sound at the appropriately configured volume.

Environmental Variables:
Device: FlameKK 2.5 (512MB)
BuildID: 20151214083757
Gaia: 062e0fa48c1b5d5156f6911a5a4519128fac3231
Gecko: d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
(Reporter)

Comment 2

3 years ago
Created attachment 8698105 [details]
logcat-alarm.txt
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 3

3 years ago
Correction: https://moztrap.mozilla.org/manage/case/1772/ is the case blocked by this bug, not case 2477.
blocking-b2g: --- → 2.6?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qaurgent, regressionwindow-wanted
QA Contact: pcheng
mozilla inbound regression window:

Last Working
Device: Flame 2.6
BuildID: 20151211074133
Gaia: d886e152b42e557db612470d3417fe2947cbdeee
Gecko: ee132b90ad4b11b03c4dcc5b21bc636ef11bbe66
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Device: Flame 2.6
BuildID: 20151211081830
Gaia: d886e152b42e557db612470d3417fe2947cbdeee
Gecko: eb3d458624eb3a62e8aebfaed322a63314153d3e
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ee132b90ad4b11b03c4dcc5b21bc636ef11bbe66&tochange=eb3d458624eb3a62e8aebfaed322a63314153d3e

Caused by changes made in Bug 1214148.
Blocks: 1214148
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qaurgent, regressionwindow-wanted
Andrea this smoketest blocker seems to have been caused by the changes for bug 1214148.  Can you please take a look?
Flags: needinfo?(jmercado) → needinfo?(amarchesini)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
See Also: → bug 1232256
See Also: bug 1232256
Based on regression window.
Component: Gaia::System::Audio Mgmt → DOM
Product: Firefox OS → Core
Version: unspecified → 46 Branch
Flags: needinfo?(amarchesini)
Should be resolved by backout of bug 1214148. Verify me, now that the latest build contains the revert.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: verifyme
Resolution: --- → FIXED
Duplicate of this bug: 1232399
Duplicate of this bug: 1232366
Duplicate of this bug: 1232359
(Reporter)

Comment 11

3 years ago
This issue is verified fixed on the latest Aries and Flame 2.6 builds.
Alarm audio channel creates audible sound properly. Touch Tones work properly in a call. The Video app will correctly play videos.

Environmental Variables:
Device: Aries 2.6
BuildID: 20151215145647
Gaia: ee43a95f2bbe39c5ac8c9fcdec76749a56c02f2e
Gecko: cb66ffeb6725e8344818e8e2f707ae2eaeb953b4
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Environmental Variables:
Device: FlameKK 2.6 (512MB)
BuildID: 20151215145230
Gaia: ee43a95f2bbe39c5ac8c9fcdec76749a56c02f2e
Gecko: cb66ffeb6725e8344818e8e2f707ae2eaeb953b4
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: affected → verified
Flags: needinfo?(jmercado)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
(Assignee)

Comment 12

3 years ago
I'll update the solution and then we can land the bug1214148.
Assignee: nobody → alwu
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

3 years ago
Component: DOM → AudioChannel
Product: Core → Firefox OS
Version: 46 Branch → unspecified
Created attachment 8699817 [details] [review]
[gaia] alastor0325:bug1232363_noAlarmSound > mozilla-b2g:master
(Assignee)

Comment 14

3 years ago
Comment on attachment 8699817 [details] [review]
[gaia] alastor0325:bug1232363_noAlarmSound > mozilla-b2g:master

Hi, Evan,

Could you help me to review this patch?
Very appreciate!

---

In bug1214148, we try to solve the issue of the nested-mozBrowserFrame.

If we're in the nested case, the audio channels of the children need to be the subset of the parent's. Therefore, the system app should have all audio channel permissions.
Attachment #8699817 - Flags: review?(evan)
Comment on attachment 8699817 [details] [review]
[gaia] alastor0325:bug1232363_noAlarmSound > mozilla-b2g:master

LGTM.
Alastor, Thanks.
Attachment #8699817 - Flags: review?(evan) → review+
master: https://github.com/mozilla-b2g/gaia/commit/f3cf488a97ecaec43369f3e3d8a7dda52be019f9
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Comment 17

3 years ago
According to bug1214148 comment 93, the patch is also needed for v2.5.

So, is it possible to apply it ? (For information, the patch of bug1214908 is not applied in 2.5)

Updated

3 years ago
Flags: needinfo?(alwu)
(Assignee)

Comment 18

3 years ago
Yes, I think it can be applied into v2.5.
Flags: needinfo?(alwu)
Created attachment 8719880 [details] [review]
[gaia] micgeri:v2.5 > mozilla-b2g:v2.5

Comment 21

3 years ago
Thanks
marking as verified because micgeri did verified this fixes the issue on v2.5 also :)
status-b2g-v2.5: unaffected → verified
You need to log in before you can comment on or make changes to this bug.