Lockscreen will appear on half of screen when locking phone while transitioning to landscape

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
P2
normal
RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: AdamA, Unassigned)

Tracking

({polish, regression})

unspecified
ARM
Gonk (Firefox OS)
polish, regression

Firefox Tracking Flags

(b2g-v2.5 unaffected, b2g-master affected)

Details

(Whiteboard: [2.6-Daily-Testing][Spark][systemsfe], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8698249 [details]
logcat

Description:
If the user locks the phone while transitioning to landscape phone they will see the lockscreen appear over half of the phone for a moment before the screen locks.

Repro Steps:
1) Update a Aries to 20151214120141
2) Open an app that can go lockscreen
3) Turn the phone sideways to enter landscape
4) Lock the phone while the app is transitioning to landscape
5) Observe screen

Actual:
The lockscreen appears over half the screen while transitioning

Expected:
It is expected that the lockscreen does not cover half the screen.

Environmental Variables:
Device: Aries 2.6 [KK][Full Flash]
Build ID: 20151214120141
Gaia: ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gecko: 99137d6d4061f408ae0869122649d8bdf489cc30
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 10/10
See attached: video clip(https://youtu.be/PUO5576v18w), logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame 2.6.

Environmental Variables:
Device: FlameKK 2.6 [Full Flash][512mb]
Build ID: 20151214030209
Gaia: ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gecko: 99137d6d4061f408ae0869122649d8bdf489cc30
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6)
Firmware Version: v18D v4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Result:
The lockscreen appears over half the screen while transitioning
-------------------------------------------------
This issue DOES NOT occur on Flame 2.5.

Environmental Variables:
Device: FlameKK 2.5 [Full Flash][512mb]
BuildID: 20151214083757
Gaia: 062e0fa48c1b5d5156f6911a5a4519128fac3231
Gecko: d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
The screen locks after transitioning and doesnt show lockscreen.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
(Reporter)

Updated

3 years ago
Flags: needinfo?(jmercado) → needinfo?(ktucker)
blocking-b2g: --- → 2.6?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted

Updated

3 years ago
QA Contact: jthomas
We don't have the builds of the date 20151013, and only have the minimum range with Build ID 20151012141541 and Build ID 20151014005117 in b2g-inbound as last working and first broken.

b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK v2.5
Build ID               20151012141541
Gaia Revision          470ecf899417957f414507b73213a816006ff5da
Gaia Date              2015-10-12 18:03:06
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/465dcb647ce750a7e15b93c28f5b3932c4b6546a
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151012.183433
Firmware Date          Mon Oct 12 18:34:45 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK v2.5
Build ID               20151014005117
Gaia Revision          df7683e4f7329c567deb487d11317578c6930246
Gaia Date              2015-10-14 06:23:14
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/51b3fd0353d8dc98f1c55d14429bd21d8289259d
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151012.183433
Firmware Date          Mon Oct 12 18:34:45 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          df7683e4f7329c567deb487d11317578c6930246
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/465dcb647ce750a7e15b93c28f5b3932c4b6546a

First Broken Gecko & Last Working Gaia – issue DOES NOT repro
Gaia Revision          470ecf899417957f414507b73213a816006ff5da
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/51b3fd0353d8dc98f1c55d14429bd21d8289259d

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/470ecf899417957f414507b73213a816006ff5da...df7683e4f7329c567deb487d11317578c6930246
QA Whiteboard: [MGSEI-Triage+]
Keywords: regressionwindow-wanted
Not blocking since there is no serious user impact.
blocking-b2g: 2.6? → ---
Keywords: polish
Priority: -- → P2
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][systemsfe]

Comment 4

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.