Closed Bug 12325 Opened 20 years ago Closed 20 years ago

Hanging in Pop3Protocol

Categories

(MailNews Core :: Backend, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: scottputterman, Assigned: mscott)

Details

(Whiteboard: [PR1])

If I let the 3pane run long enough I will eventually hang.  Whenever I break in
the debugger it is somewhere in nsPop3Protocol.cpp.  It's easy to reproduce
because it happens all of the time, but I don't know what's causing it.
Sometimes it happens reasonably close to when I start up. Sometimes it happens
15 minutes later.  Sometimes I have a message selected. Sometimes I haven't even
opened a folder.

One possibility is that it's related to biff.  I haven't tried turning that off.
Status: NEW → ASSIGNED
Target Milestone: M10
M10. Accepting.

Scott, were you seeing this before friday? Or it started in Friday's builds? I
haven't seen it yet but I don't have biff on for windows (well I do but the
interval is like 1 hour and i'm never running that long).

Investigating..
Friday was the first day I saw this.
This bug may be effected by my bug fix tonight for #11895. It also may be fixed
when Bug #12850 is resolved as both of these could lead to weird problems like
what scott is reporting in this bug.
Bulk move mail/news M10 bugs to M11
Whiteboard: [PR1]
I think this needs to be fixed by PR1, so I added a note in the Status
Whiteboard. Unless, of course, this has already been fixed.
So, I haven't seen this in a while, but I've also changed biff so that it
doesn't go off if you don't have a password so I basically don't use biff
anymore.  I've always suspected there might be some correlation between the two.
Anyway, just adding this in case it means anything.
Scott, if you want to turn biff back on, just set the remember_password pref and
it should again (after the next time you enter a password of course).
Scott, have you seen this problem with biff turned on recently? I still think my
fix for #12850 could have fixed this one too.
Scott,

Sorry, I haven't turned biff back on yet.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I'm not seeing this anymore and I think 12850 fixed this. Marking as fixed.
Status: RESOLVED → VERIFIED
marking verified since Scott Putterman says this is now working.  Thanks!
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.