[TV][2.5] When uninstall an app, confirmation dialog show "OK"/"OK" (should be "OK"/"Cancel")

RESOLVED DUPLICATE of bug 1201013

Status

Firefox OS
Gaia::TV::Home
RESOLVED DUPLICATE of bug 1201013
2 years ago
2 years ago

People

(Reporter: Taro Suzuki, Assigned: Fischer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8698309 [details]
NG case of confirmation dialog (OK/OK)

1. press "APPS" key and select YouTube App
2. press "OPTION" key, and select uninstall 
3. enter PIN code
4. confirmation dialog show "OK"/"OK"
Expected: should be should be "OK"/"Cancel"

Detail:
AppDeck calls "window.confim()", and systemApp shows this panel using
ModalDialog[1]. it seems not to be set 'textL10nId' correctly.
TurtorialApp use the same panel but there is no problem.

[1]: https://github.com/mozilla/stingray-gaia/blob/panasonic-v2.5-basedon-mozilla2.5/tv_apps/smart-system/js/app_modal_dialog.js#L264

Updated

2 years ago
Assignee: nobody → fliu
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1201013
You need to log in before you can comment on or make changes to this bug.