TabManagerTests testTabManagerStoresChangesInDB failed: caught "NSInternalInconsistencyException", "Completion handler passed to -[FennecAurora.TabManagerNavDelegate webView:didReceiveAuthenticationChallenge:completionHandler:] was not called

RESOLVED FIXED

Status

()

Firefox for iOS
Build & Test
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: rnewman, Assigned: fluffyemily)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

48 bytes, text/x-github-pull-request
sleroux
: review+
Details | Review | Splinter Review
(Reporter)

Description

3 years ago
2015-12-14 20:20:56.081 [Debug] [SwiftData.swift:548] executeQuery(_:factory:withArgs:) > Running query SELECT * FROM tabs WHERE client_guid IS NULL;
2015-12-14 20:20:56.082 [Debug] [SQLiteRemoteClientsAndTabs.swift:181] getTabsForClientWithGUID > Found 0 tabs for client with guid: nil
/Users/rnewman/moz/git/s2fxios/ClientTests/XCTestCaseExtensions.swift:15: error: -[FennecAurora.TabManagerTests testTabManagerStoresChangesInDB] : failed: caught "NSInternalInconsistencyException", "Completion handler passed to -[FennecAurora.TabManagerNavDelegate webView:didReceiveAuthenticationChallenge:completionHandler:] was not called"
(
	0   CoreFoundation                      0x000000010cb74e65 __exceptionPreprocess + 165
	1   libobjc.A.dylib                     0x000000010be94deb objc_exception_throw + 48
	2   CoreFoundation                      0x000000010cb74d9d +[NSException raise:format:] + 205
	3   WebKit                              0x000000010edbd9f0 _ZN6WebKit28CompletionHandlerCallCheckerD2Ev + 130
	4   WebKit                              0x000000010f00666c _ZN3WTF20ThreadSafeRefCountedIN6WebKit28CompletionHandlerCallCheckerEE5derefEv + 36
	5   WebKit                              0x000000010ee03616 _ZN6WebKit15NavigationState16NavigationClient33didReceiveAuthenticationChallengeERNS_12WebPageProxyEPNS_28AuthenticationChallengeProxyE + 362
	6   WebKit                              0x000000010ef345b2 _ZN6WebKit12WebPageProxy38didReceiveAuthenticationChallengeProxyEyN3WTF10PassRefPtrINS_28AuthenticationChallengeProxyEEE + 64
	7   WebKit                              0x000000010ee28acf _ZN6WebKit19NetworkProcessProxy33didReceiveAuthenticationChallengeEyyRKN7WebCore23AuthenticationChallengeEy + 105
	8   WebKit                              0x000000010ee2a53e _ZN3IPC13handleMessageIN8Messages19NetworkProcessProxy33DidReceiveAuthenticationChallengeEN6WebKit19NetworkProcessProxyEMS5_FvyyRKN7WebCore23AuthenticationChallengeEyEEEvRNS_14MessageDecoderEPT0_T1_ + 159
	9   WebKit                              0x000000010edbddca _ZN3IPC10Connection15dispatchMessageENSt3__110unique_ptrINS_14MessageDecoderENS1_14default_deleteIS3_EEEE + 102
	10  WebKit                              0x000000010edc0092 _ZN3IPC10Connection18dispatchOneMessageEv + 114
	11  JavaScriptCore                      0x0000000117dbcb05 _ZN3WTF7RunLoop11performWorkEv + 437
	12  JavaScriptCore                      0x0000000117dbd1e2 _ZN3WTF7RunLoop11performWorkEPv + 34
	13  CoreFoundation                      0x000000010caa0a31 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
	14  CoreFoundation                      0x000000010ca9695c __CFRunLoopDoSources0 + 556
	15  CoreFoundation                      0x000000010ca95e13 __CFRunLoopRun + 867
	16  CoreFoundation                      0x000000010ca95828 CFRunLoopRunSpecific + 488
	17  Foundation                          0x000000010ba812f1 -[NSRunLoop(NSRunLoop) runMode:beforeDate:] + 267
	18  XCTest                              0x000000011c9a0b1d -[XCTestCase(AsynchronousTesting) waitForExpectationsWithTimeout:handler:] + 921
	19  FennecAurora                        0x0000000121cf6fe5 _TFE12FennecAuroraCSo10XCTestCase4waitfS0_FSdT_ + 1157
	20  FennecAurora                        0x0000000121cf71ec _TToFE12FennecAuroraCSo10XCTestCase4waitfS0_FSdT_ + 44
	21  FennecAurora                        0x0000000121cf739a _TFE12FennecAuroraCSo10XCTestCase16waitForConditionfS0_FT7timeoutSd9conditionFT_Sb_T_ + 394
	22  FennecAurora                        0x0000000121cf743d _TToFE12FennecAuroraCSo10XCTestCase16waitForConditionfS0_FT7timeoutSd9conditionFT_Sb_T_ + 125
	23  FennecAurora                        0x0000000121d32f5a _TFC12FennecAurora15TabManagerTests31testTabManagerStoresChangesInDBfS0_FT_T_ + 2250
	24  FennecAurora                        0x0000000121d33e92 _TToFC12FennecAurora15TabManagerTests31testTabManagerStoresChangesInDBfS0_FT_T_ + 34
	25  CoreFoundation                      0x000000010ca631cc __invoking___ + 140
	26  CoreFoundation                      0x000000010ca6301e -[NSInvocation invoke] + 286
	27  XCTest                              0x000000011c959080 __24-[XCTestCase invokeTest]_block_invoke_2 + 159
	28  XCTest                              0x000000011c98cb14 -[XCTestContext performInScope:] + 184
	29  XCTest                              0x000000011c958fd0 -[XCTestCase invokeTest] + 169
	30  XCTest                              0x000000011c95946b -[XCTestCase performTest:] + 443
	31  XCTest                              0x000000011c957131 -[XCTestSuite performTest:] + 377
	32  XCTest                              0x000000011c957131 -[XCTestSuite performTest:] + 377
	33  XCTest                              0x000000011c944181 __25-[XCTestDriver _runSuite]_block_invoke + 51
	34  XCTest                              0x000000011c964b5b -[XCTestObservationCenter _observeTestExecutionForBlock:] + 615
	35  XCTest                              0x000000011c9440cd -[XCTestDriver _runSuite] + 408
	36  XCTest                              0x000000011c944e2c -[XCTestDriver _checkForTestManager] + 263
	37  XCTest                              0x000000011c98de99 _XCTestMain + 628
	38  CoreFoundation                      0x000000010caa0a1c __CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK__ + 12
	39  CoreFoundation                      0x000000010ca966a5 __CFRunLoopDoBlocks + 341
	40  CoreFoundation                      0x000000010ca95e02 __CFRunLoopRun + 850
	41  CoreFoundation                      0x000000010ca95828
(Reporter)

Comment 1

3 years ago
This is failing on master for me.
(Assignee)

Updated

2 years ago
Assignee: nobody → etoop
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 years ago
Created attachment 8720729 [details] [review]
Pull request

The test still fails. Will raise another bug for that.
Attachment #8720729 - Flags: review?(sleroux)
Comment on attachment 8720729 [details] [review]
Pull request

Works for me. Added a suggestion that might help clean up the method a bit.
Attachment #8720729 - Flags: review?(sleroux) → review+
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1249436
You need to log in before you can comment on or make changes to this bug.