Mails downloaded for offline use still have the envelope icon next to the subject

VERIFIED DUPLICATE of bug 86897

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED DUPLICATE of bug 86897
17 years ago
14 years ago

People

(Reporter: sai allavarpu, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020201
BuildID:    2002020103

In 0.9.7 release of Mozilla, when I used to download messages for offline use
(IMAP), the envelope icon next to the subject in the Mail message summary window
used to disappear (the right behavior). When there is no envelope icon, users
would have a visual indication/confirmation that the  messages have been
downloaded for offline use.

However, in the build 2002020103 (to be used for 0.9.8+) has broken this visual
confirmation. Now, when the mails are downloaded for offline use, the envelope
icon next to the subject doesn't go away; thereby there is no visual indication
or confirmation as to whether the messages are downloaded for offline use or not.

Please fix this bug to reflect the behavior in 0.9.7 (when messages are
downloaded for offline use, the envelope icon next to the subject should
disappear there giving a visual indication that offline download  succeeded).
Don't release 0.9.8 without this fix.

Reproducible: Always
Steps to Reproduce:
1.Log in to your IMAP mail
2.You will see the enveolpe icon next to subject in the mail summary window.
3.Now go offline and try to download all INBOX mails. The mails are downloaded
but the envelope is still (wrongly) there next to each subject in each mail.

Expected Results:  When messages are downloaded for offline use, there should be
a visual confirmation/indication in the mail summary window as to which of the
mails are downloaded for offline use. No envelope icon next to the subject in
each mail should indicate that the mails are downloaded for offline use.
Envelope icon next to subject in each mail should indicate that mails are not
downloaded for offline use.

Comment 1

17 years ago
this works fine for me. Are you sure the folder in question is still configured
for offline use? If you bring up the properties dialog for the folder, in the
offline tab, is the folder still configured for offline use?

Comment 2

17 years ago
Reporter using 2002020103 build on nt 4.0, I don't see this problem
but I think I know what you are talking about.

First I bet you were in classic theme?
And when you downloaded mail the envelope icon dissapeared.
Well there was a bug on that: bug 67359. And if you
look at my comment in that bug 
http://bugzilla.mozilla.org/show_bug.cgi?id=67359#c44
you'll see it was a mistake (for envelope icon to dissapear).
Classic had envelope icon disspearing (modern theme did not).


You should now see a darker kind of blue/purplish envelope for
downloaded mesgs & white envelope for non-downloaded mesg.

Will resolve as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

17 years ago
NOTE: In Classic theme, the envelope icon disappears (actually, I like that
behavior as it is visually more effective). In Modern theme, the icon stays. But
the icon doesn't change (white to blue) for offline downloaded messages. BTW, I
was using Windows 2000 (not NT).

In Modern theme, the colors dont' change either. So the bug is still valid
(although with the Modern theme, then): no visual indication whether the
messages are downloaded for offline use or not.

Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

17 years ago
Reporter, I am using 2002020103 on NT 4.0 

and I see nothing wrong with envelope icons in either
modern or classic theme.

Click folder (don't actually select a mesg)
You should see this
 modern: Dark gray envelope for downloaded mesgs
         light gray envelope for non-downloaded mesgs

 Classic: Bluish/Purplish envelope for downloaded mesgs
          White envelope for non-downloaded mesgs

The difference between a downloaded and non-downloaded mesg
is supposed to be SUBTLE. 

I think you are mistaken, please try again. I know it's
kind of hard to tell sometimes.
(Reporter)

Comment 5

17 years ago
As I mentioned, gchan is right. But the issue is with the "subtle" difference.
I ran a quick usability study with several other people. Some messages were
downloaded for offline use and some weren't. People were asked to tell the
difference. Here are the results of such a study:

Classic theme: The visual difference is "slightly" noticeable. But if the person
is using a laptop in an airport or on a flight (or other glare conditions),
he/she has to strain the eyes to figure out the difference.

Modern Theme; The visual difference is "worse" than in the classic theme. Even
in the best of lighting conditions, most people couldn't tell the light
gray/dark gray difference.

Suggestion: Like Outlook Express or Eudora, rely on a different icon shape
rather  than slight/subtle color shades (especially for the color-challenged!).
If you can't use different icon shapes, then at least use different
high-contrast colors instead of low-contrast colors or shades of the same color.
People actually liked the "old bug" in classic theme where the icon disappears
when the message is downloaded for offline use; they don't need the mail icon
otherwise just to indicate that it is a message!

People don't want to be caught on a long travel/flight with the mistaken
assumption that the messages were downloaded while there weren't.

Comment 6

17 years ago
if this is going to turn out to be a bug about the visual display of the icon,
it should be assigned to someone in the UE group and the component should be FE.
(Reporter)

Comment 7

17 years ago
Changed the component to "MailWindow Front End" per the suggestion.
Assignee: bienvenu → sspitzer
Component: Offline → Mail Window Front End
QA Contact: gchan → esther

Comment 8

17 years ago
There's already a bug on this.

Bug 86897 covers envelope icon. 
Mainly Modern theme but I think classic theme could
be applied there to.

Please add your comments to that bug.

Marking as dupe.

*** This bug has been marked as a duplicate of 86897 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
QA Contact: esther → gchan
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.