[Video]Recording video will make the music in background resume playing.

VERIFIED DUPLICATE of bug 1232348

Status

Firefox OS
Gaia::Video
--
major
VERIFIED DUPLICATE of bug 1232348
2 years ago
2 years ago

People

(Reporter: SandKing, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.5 unaffected, b2g-master verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8698322 [details]
Bug log: logcat_2313.txt

[1.Description]:
[Flame master][Aries KK master][Video]Music in background is paused by launching "Camera", but it resumes playing when user starts to record video in Camera.
See video: "Aries_master.3gp"
See log:"logcat_2313.txt"
Found Time:23:13

[2.Testing Steps]: 
Precondition: There are some music files in device.
1. Launch Music and play a song.
2. Press Home key to let the music play in background.
3. Launch Camera.
**The music will be stopped.
4. Switch to Video mode.
5. Tap record icon.

[3.Expected Result]: 
5. The video should begin to record and the music should not play.

[4.Actual Result]: 
5. The video begin to record and the music resumes playing.

[5.Reproduction build]: 
Flame master_512M(Affected):
Build ID               20151214150211
Gaia Revision          ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gaia Date              2015-12-13 23:23:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/06ab805e14b5e6d8a8a99c7846c8fde163a9e5d7
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151214.182440
Firmware Date          Mon Dec 14 18:24:52 EST 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

Flame v2.5_512M (Unaffected)
Build ID               20151214083757
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151214.074606
Firmware Date          Mon Dec 14 07:46:17 UTC 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

Flame v2.2_512M (Unaffected)
Build ID               20151214032502
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/772a4e56d15d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151214.064632
Firmware Date          Mon Dec 14 06:46:43 EST 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

Aries KK master (Affected)
Build ID               20151215010221
Gaia Revision          ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gaia Date              2015-12-13 23:23:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ae37fdb042c07c0cb9d0afcd41372a96454f4f4f
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151215.002304
Firmware Date          Tue Dec 15 00:23:12 UTC 2015
Bootloader             s1

Aries KK v2.5 (Unaffected)
Build ID               20151214084334
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151214.074854
Firmware Date          Mon Dec 14 07:49:02 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

2 years ago
Created attachment 8698323 [details]
Bug video: Aries_master.3GP
(Reporter)

Updated

2 years ago
status-b2g-v2.5: --- → unaffected
status-b2g-master: --- → affected
Keywords: regression
QA Contact: liuke
mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device:Flame KK master (512mb)
Build ID               20151211074133
Gaia Revision          d886e152b42e557db612470d3417fe2947cbdeee
Gaia Date              2015-12-10 21:39:23
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/ee132b90ad4b11b03c4dcc5b21bc636ef11bbe66
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151212.182602
Firmware Date          Sat Dec 12 18:26:14 EST 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK master (512mb)
Build ID               20151211081830
Gaia Revision          d886e152b42e557db612470d3417fe2947cbdeee
Gaia Date              2015-12-10 21:39:23
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/eb3d458624eb3a62e8aebfaed322a63314153d3e
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151212.182602
Firmware Date          Sat Dec 12 18:26:14 EST 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES NOT repro
Gaia Revision
d886e152b42e557db612470d3417fe2947cbdeee
Gecko Revision 
https://hg.mozilla.org/integration/mozilla-inbound/rev/ee132b90ad4b11b03c4dcc5b21bc636ef11bbe66

First Broken Gecko & Last Working Gaia – issue DOES repro
Gaia Revision
d886e152b42e557db612470d3417fe2947cbdeee
Gecko Revision  
https://hg.mozilla.org/integration/mozilla-inbound/rev/eb3d458624eb3a62e8aebfaed322a63314153d3e

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ee132b90ad4b11b03c4dcc5b21bc636ef11bbe66&tochange=eb3d458624eb3a62e8aebfaed322a63314153d3e

Hi Andrea,
   This bug is possibly caused by Bug 1214148, could you please help to take a look?
Thank you very much.
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(amarchesini)
QA Contact: liuke
Alwu, can you take a look?
Flags: needinfo?(amarchesini) → needinfo?(alwu)
Sure, I think it might be the same root cause of the bug1232348.
I am still debugging now. (have idea but not clear)
Same root cause.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(alwu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1232348
  This bug has been verified as "pass" on the latest build of Flame KK master and Aries KK master by the STR in comment 0.

Actual results: The video can begin to record and the music can not play in step 5.
See attachment: verified_Aries KK_master.3gp.
Reproduce rate: 0/10


Device: Flame KK master (Pass)
Build ID               20151228150204
Gaia Revision          15a00047c0868cc8f4c8ec4af253b82ac54d70dd
Gaia Date              2015-12-26 05:30:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7c83da46ea740bc14028aca9f9a662f062de5586
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151228.185050
Firmware Date          Mon Dec 28 18:51:03 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master (Pass)
Build ID               20151228092606
Gaia Revision          15a00047c0868cc8f4c8ec4af253b82ac54d70dd
Gaia Date              2015-12-26 05:30:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7c83da46ea740bc14028aca9f9a662f062de5586
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151228.095413
Firmware Date          Mon Dec 28 09:54:21 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
status-b2g-master: affected → verified
Created attachment 8702468 [details]
verified_Aries KK_master.3gp
You need to log in before you can comment on or make changes to this bug.