Closed Bug 1232602 Opened 6 years ago Closed 6 years ago

[Camera]Play the song from notification on viewfinder and hide the notification, the viewfinder is frozen.

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 unaffected, b2g-v2.5 affected, b2g-master verified)

RESOLVED DUPLICATE of bug 1228564
Tracking Status
b2g-v2.2 --- unaffected
b2g-v2.5 --- affected
b2g-master --- verified

People

(Reporter: yulan.zhu, Assigned: mchiang)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached video AriesKK_v2.5_video.3gp
[1.Description]:
[AriesKK v2.5&master][FlameKK v2.5][Camera]Play the song from notification on viewfinder and hide the notification, the viewfinder is frozen.
See attachment:AriesKK_v2.5_video.3gp and logcat.txt.
Occurrence time:15:52

[2.Testing Steps]: 
Precondition:Several songs in DUT.

1.Launch Music and play a song.
2.Pause the playing song and go back to homescreen.
3.Launch Camera.
4.Open Notifications menu and resume to play the song.
5.Hide the Notifications menu.

[3.Expected Result]: 
5.The viewfinder should not be frozen.

[4.Actual Result]: 
5.The viewfinder is frozen.

[5.Reproduction build]: 
Device: AriesKK v2.5 build (Affected)
Build ID               20151214084334
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151214.074854
Firmware Date          Mon Dec 14 07:49:02 UTC 2015
Bootloader             s1

Device: AriesKK master build (Affected)
Build ID               20151215010221
Gaia Revision          ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gaia Date              2015-12-13 23:23:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ae37fdb042c07c0cb9d0afcd41372a96454f4f4f
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151215.002304
Firmware Date          Tue Dec 15 00:23:12 UTC 2015
Bootloader             s1

Device: FlameKK v2.5 build (Affected)
Build ID               20151214083757
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151214.074606
Firmware Date          Mon Dec 14 07:46:17 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: FlameKK master build (Unaffected)
Build ID               20151214150211
Gaia Revision          ad15b4f1f50f4e28170a069f049e5bdeec8d15cc
Gaia Date              2015-12-13 23:23:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/06ab805e14b5e6d8a8a99c7846c8fde163a9e5d7
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151214.182440
Firmware Date          Mon Dec 14 18:24:52 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
Attached file logcat.txt
This bug can't be repro on latest Flame v2.2 by the STR in comment 0.

Actual results: The viewfinder is not frozen and can continue to capture picture normally.
Reproduce rate: 0/10


Device: Flame 2.2_512mb (unaffected) 
Build ID               20151215032500
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2c21da79a810
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151215.071117
Firmware Date          Tue Dec 15 07:11:28 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
QA Whiteboard: [severe][MGSEI-Triage+]
Keywords: regression
We have no "Last Working" and "First Broken" builds in mozilla-inbound, so I try to find this regressionwindow in b2g-inbound. Hope this helps.


b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 2.5 (512mb)
Build ID               20151023105433
Gaia Revision          98264793f49a44e5729102617cc7b39052790108
Gaia Date              2015-10-23 16:58:16
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/990101b9129775bf1d45ec90ca2bb98ba2437817
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151025.064339
Firmware Date          Sun Oct 25 06:43:52 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame 2.5(512mb)
Build ID               20151023215433
Gaia Revision          c9843aa2a30b9a87bbfa2cf03e10d3ad6e217d07
Gaia Date              2015-10-24 04:09:28
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/6659a9b5cfe361962e72df8855df2fbfdc013d8f
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151025.064339
Firmware Date          Sun Oct 25 06:43:52 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES NOT repro
Gaia-Rev        c9843aa2a30b9a87bbfa2cf03e10d3ad6e217d07
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/990101b9129775bf1d45ec90ca2bb98ba2437817

First Broken Gecko & Last Working Gaia - issue DOES repro
Gaia-Rev        98264793f49a44e5729102617cc7b39052790108
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/6659a9b5cfe361962e72df8855df2fbfdc013d8f


Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=990101b9129775bf1d45ec90ca2bb98ba2437817&tochange=6659a9b5cfe361962e72df8855df2fbfdc013d8f
Let's see if we can find a smaller window here.
QA Contact: mmurrell
QA Contact: mmurrell → jthomas
Caused by changes made in Bug 1212783

Mozilla Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20151022204451
Gaia: f4c7fbf7a3ae24315b7937c77cdaf7cdb127ff86
Gecko: abaedc34e7e91a204abccf4d6578e7d5ebf430d6
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20151022205632
Gaia: f4c7fbf7a3ae24315b7937c77cdaf7cdb127ff86
Gecko: cfd7882e6f70d4d824e4af91fa3ac0591c884ebb
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working gaia / First Broken gecko - This issue DOES occur with broken Gecko
Gaia: f4c7fbf7a3ae24315b7937c77cdaf7cdb127ff86
Gecko: cfd7882e6f70d4d824e4af91fa3ac0591c884ebb

Last Working gecko / First Broken gaia - This issue does NOT occur with broken Gaia
Gecko: abaedc34e7e91a204abccf4d6578e7d5ebf430d6
Gaia: f4c7fbf7a3ae24315b7937c77cdaf7cdb127ff86

Mozilla Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=abaedc34e7e91a204abccf4d6578e7d5ebf430d6&tochange=cfd7882e6f70d4d824e4af91fa3ac0591c884ebb
Blocks: 1212783
QA Whiteboard: [severe][MGSEI-Triage+] → [QAnalyst-Triage?][severe][MGSEI-Triage+]
Flags: needinfo?(jmercado)
Andreas this seems to have been caused by the changes for bug 1212783.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?][severe][MGSEI-Triage+] → [QAnalyst-Triage+][severe][MGSEI-Triage+]
Flags: needinfo?(pehrsons)
Flags: needinfo?(npark)
Flags: needinfo?(jmercado)
Nominating to 2.6 blocker for broken functionality
blocking-b2g: --- → 2.6?
Flags: needinfo?(npark)
There's nothing obvious from bug 1212783 that I see would be wrong. I'm not set up for building or debugging b2g at the moment so I'm trying to get help from Taipei on that part.
(In reply to Andreas Pehrson [:pehrsons] (Telenor) from comment #8)
> There's nothing obvious from bug 1212783 that I see would be wrong. I'm not
> set up for building or debugging b2g at the moment so I'm trying to get help
> from Taipei on that part.
Sure!:-) 
Murno, 
Could you help on this one? 
Thanks!
Flags: needinfo?(pehrsons) → needinfo?(mchiang)
Assignee: nobody → mchiang
Flags: needinfo?(mchiang)
In bug 1212783, we added a MediaStreamTrack to DOMCameraControl. With this patch, HTMLMediaElement will remove the playback of CameraPreviewMediaStream after other HTMLMediaElement playback begins. For CameraPreviewMediaStream, we should always keep it alive.
Attachment #8701980 - Flags: review?(pehrsons)
Attachment #8701980 - Flags: review?(aosmond)
(In reply to Munro Chiang [:munro_chiang] from comment #10)
> HTMLMediaElement will remove the playback of CameraPreviewMediaStream
> after other HTMLMediaElement playback begins.

Hmm, I'd like to know more about this. Generally we can have multiple media elements active at the same time, why not here?
Flags: needinfo?(mchiang)
Attachment #8701980 - Flags: review?(pehrsons)
Alastor, this behavior may be related to the audio channel competition mechanism. Could you help check?
Flags: needinfo?(mchiang) → needinfo?(alwu)
Non-audible media element shouldn't involve in audio competing, this issue has been solved in latest m-c.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(alwu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1228564
Can QA verify that this works now? Thanks.
Keywords: qawanted
This bug has been verified as pass on latest build of Aries KK master by the STR in comment 0.

Actual results: The viewfinder does not be frozen after resuming to play the song in notification menu.

See attachment: verified Aries_kk master.3gp

Reproduce rate: 0/10

Device: Aries kk master(Pass)
Build ID               20160104105544
Gaia Revision          765d98a20f903ed34b91814e1ad0ce4181fba548
Gaia Date              2016-01-04 05:38:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0771c5eab32f0cee4f7d12bc382298a81e0eabb2
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20160104.112129
Firmware Date          Mon Jan  4 11:21:37 UTC 2016
Bootloader             s1
blocking-b2g: 2.6? → ---
Attachment #8701980 - Flags: review?(aosmond)
You need to log in before you can comment on or make changes to this bug.