Error to show transaction log page of payment accounts

VERIFIED FIXED

Status

Marketplace
General
P2
critical
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: marsf, Assigned: jason)

Tracking

Avenir
Points:
---

Details

(Reporter)

Description

2 years ago
When try to showing transaction page of my payment account from "Compatibility & Payments" > "Payment Accounts" > "View Transactions", following error page is shown.

http://mozilla.com.test.bango.org/?err=ERROR_INVALID_PACKAGE
> Bango Vendor Portal
> The package you have tried to access is invalid. You are not able to continue at this time.

There is no change in my app nor account when the error is occured. It occures unexpectedly since this month. I'm not sure what is happend to bango account.
Before the error, I could see transaction log of my payment account.
(Reporter)

Updated

2 years ago
Flags: needinfo?(kumar.mcmillan)
What was the URL of the page you were clicking the 'view transactions' link from? This error makes it look like you are using a development site, not the production site.
Flags: needinfo?(kumar.mcmillan) → needinfo?(chimantaea_mirabilis)
(Reporter)

Comment 2

2 years ago
"Add, manage or view transactions for your payment accounts" under "Payment Accounts" section of those pages:

https://marketplace.firefox.com/developers/app/uninput/payments/
https://marketplace.firefox.com/developers/app/hyakunin-isshu/payments/

They use same payment account and shows same error page.
Am I redirected from production site to development site?
Flags: needinfo?(chimantaea_mirabilis)
(Reporter)

Comment 3

2 years ago
Any thoughts?
Flags: needinfo?(kumar.mcmillan)
ok, that is definitely a production link. Actually, maybe http://mozilla.com.test.bango.org/ is the real URL. I don't know, hah. Looks like a test URL. I'm not sure what the error is about. Andy might be able to help prioritize looking into this. I don't have any payment accounts in production to try reproducing it.
Flags: needinfo?(kumar.mcmillan) → needinfo?(amckay)

Comment 5

2 years ago
I think someone nuked that setting. It should be:

BANGO_BASE_PORTAL_URL = 'https://mozilla.bango.com/login/al.aspx?'

I suspect it happened in this commit:

https://github.com/mozilla/zamboni/commit/710241fe85591a9080bb3b60b2ae03357a9bbc99#diff-1a388eaa8d81768c26bb5381e8732f63L121

I'm not sure when the next push is for marketplace, but I think ddurst team can probably handle fixing this one up.
Flags: needinfo?(amckay) → needinfo?(ddurst)
Yeah. Next push is 1/12.
Assignee: nobody → jthomas
Priority: -- → P2
(Assignee)

Comment 7

2 years ago
Added back to zamboni https://github.com/mozilla/zamboni/commit/48a6ddc751777cb27bbcee1c950c9c2031cf5bea. Sorry!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

2 years ago
Flags: needinfo?(ddurst)
(Reporter)

Comment 8

2 years ago
Verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.