Closed Bug 1232640 Opened 4 years ago Closed 4 years ago

[e10s] Mouse cursor disappears after moving it outside the Flash video area (JW Player) on x64 bulds

Categories

(Core :: General, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s - ---

People

(Reporter: alice0775, Assigned: bobowen)

References

Details

(Keywords: regression, testcase, Whiteboard: sb?)

+++ This bug was initially created as a clone of Bug #1222662 comment#33 +++


The problem does not happen without e10s.
This is for x64 build specific problem.

Reproducible: 100%

STR:
1) Open the testcase attachment 8684466 [details] of Bug #1222630
2) disable the mixed content protection when running the testcase
3) start the video
4) enter Video's fullscreen mode and then back to normal
5) Hover the mouse over the video area
6) Move the mouse outside the video (do not move it outside content area)

Actual Result:
 mouse cursor disappears.

Expected Results:
 mouse cursor should be default(pointer)

And Bug 1222662 dod not fix the problem
Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7563e84f6efc72e380aac6d43336df93ad004462&tochange=29467b3d2124

Regressed by: 	2f47017b463b	Jim Mathies — Bug 1199892 - "Mouse cursor flickers in Flash object with wmode opaque/transparent". r=roc
No longer depends on: 1222662
Summary: [e10s] Mouse cursor disappears after moving it outside the Flash video area (JW Player) → [e10s] Mouse cursor disappears after moving it outside the Flash video area (JW Player) on x64 bulds
Duplicate of this bug: 1232633
Assignee: nobody → bobowen.code
We should retest, I had to land about three different fixes in bug 1199892 until I found something that worked reliably. In the end I had to forward all set cursor calls over. I don't see why this would break with the sandbox.
Whiteboard: sb?
I can't reproduce, Alice can you re-test please.
Flags: needinfo?(alice0775)
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(alice0775)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.