Deploy Mercurial on Windows using wheels

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: gps, Unassigned)

Tracking

Details

(Whiteboard: [windows])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8698472 [details]
mercurial-3.6.2-cp27-none-win_amd64.whl

+++ This bug was initially created as a clone of Bug #1144474 +++

From my reading of bug 1144474, the Mercurial install situation on Windows is still far from optimal. This bug tracks installing Mercurial from a Python wheels package (which should enable us to `pip install Mercurial`.

I recently patched upstream so wheels on Windows are produced more properly. It's doubtful we'll see any official Mercurial wheels before the 3.7 release. However, there's nothing stopping me from cherry picking my changes and packaging 3.6 as a wheel!

Attached is a wheel for 64-bit Windows. It should "just work" (but it should still be tested heavily before full deploy).
(Reporter)

Comment 1

3 years ago
Created attachment 8698476 [details]
mercurial-3.6.2-cp27-none-win32.whl

And here's a 32 bit wheel.
And it includes hg.exe! My hero <3
(Reporter)

Comment 3

3 years ago
hg.bat is notably absent. That's by design: batch files can do undesirable things to arguments. So we now package either hg.exe or hg.bat. This is also not a py2exe distribution: you install this thing as a regular Python package.
Closing this bug. The python install of mercurial was hindered by the restraints of buildbot on Windows and an older version of Python being used.

Once we are crossed over to taskcluster we may want to revisit this. However, at that time Windows will not be using Puppet for configuration management.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.