Can't drag img from one browser to another

RESOLVED DUPLICATE of bug 39070

Status

()

Core
Drag and Drop
RESOLVED DUPLICATE of bug 39070
17 years ago
16 years ago

People

(Reporter: Bolian Yin, Assigned: Blake Ross)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Step of reproduce:
  1.Open two browser windows.
  2.In first browser window,open the link:
http://mozilla.org/quality/browser/front-end/testcases/drag-drop/drag-img-browser-browser/drag-img-browser-browser.html
  3.Drag the Space Shuttle image from the first browser window to the second
browser window.

Expected Results:
  The second browser window should exclusively contain the shuttle_large.jpg
image.The first browser window should remain unchanged as a result of the drag.

Actual Results:
   Nothing happened in second browser window
to drag-n-drop.
Assignee: asa → blaker
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: Drag and Drop
Ever confirmed: true
QA Contact: doronr → tpreston
(Reporter)

Comment 2

17 years ago
Created attachment 67874 [details] [diff] [review]
extracted a url from the htmlstring

I have tested on win2K and Solaris.  Please review
(Assignee)

Comment 3

17 years ago
It seems to me like the proper fix is to ensure valid paths for the urlstring in
the IMG case, where currently there is

                // var baseurl = window._content.location.href;
                // need to do some stuff with the window._content.location
                // (path?) to get base URL for image.

The problem is that this particular image is in the same directory so the src is
just the filename.
(Reporter)

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 39070 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.