Anything below the baseline of the text is cut off on editable msgIdentity

RESOLVED FIXED in Thunderbird 46.0

Status

Thunderbird
Theme
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 46.0

Thunderbird Tracking Flags

(thunderbird45+ fixed, thunderbird46 fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

2 years ago
On Linux and Vista to Win 10 anything below the baseline of the text is cut off on the editable from header.
(Assignee)

Comment 1

2 years ago
Created attachment 8698544 [details] [diff] [review]
msgIdentityFix.patch

Fix the padding.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8698544 - Flags: review?(mkmelin+mozilla)

Updated

2 years ago
tracking-thunderbird45: --- → ?

Comment 2

2 years ago
Comment on attachment 8698544 [details] [diff] [review]
msgIdentityFix.patch

Thanks. Sorry about the little disagreement about the new bug. You didn't tell me that the new CSS for the feature in bug 87987 was separate as well in bug 1159316.

This fixes the issue on Windows. I guess Magnus will check the Linux part. Mac doesn't need a fix?
Attachment #8698544 - Flags: feedback+
(Assignee)

Comment 3

2 years ago
OS X needs no fix.

Comment 4

2 years ago
Comment on attachment 8698544 [details] [diff] [review]
msgIdentityFix.patch

[Approval Request Comment]
Regression caused by (bug #): 87987
User impact if declined: Needed for the function implemented in bug 87987.
Attachment #8698544 - Flags: approval-comm-aurora?

Comment 5

2 years ago
Created attachment 8701612 [details]
cutoff-g.png

So is this about that e.g. the lower part of g in Magnus is cut off slightly? The patch doesn't seem to fix that - the g is still not fully showing.

Comment 6

2 years ago
Created attachment 8701617 [details]
Looks good on Windows

> So is this about that e.g. the lower part of g in Magnus is
> cut off slightly?
Yes it is. Looks good on Windows.
(sorry about the Aurora request, I thought it would be OK on Linux, too).
(Assignee)

Comment 7

2 years ago
Created attachment 8701625 [details] [diff] [review]
msgIdentityFix.patch v2

On my Linux it worked. This change should force the .menulist-editable-box to use the full available height.
Attachment #8698544 - Attachment is obsolete: true
Attachment #8698544 - Flags: review?(mkmelin+mozilla)
Attachment #8698544 - Flags: approval-comm-aurora?
Attachment #8701625 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 8

2 years ago
Jörg, I'll ask after check-in for aurora.

Comment 9

2 years ago
Comment on attachment 8701625 [details] [diff] [review]
msgIdentityFix.patch v2

Review of attachment 8701625 [details] [diff] [review]:
-----------------------------------------------------------------

Yes this seems to work thx! r=mkmelin
Attachment #8701625 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 10

2 years ago
https://hg.mozilla.org/comm-central/rev/87c41c8ddae1 -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

2 years ago
status-thunderbird45: --- → affected
status-thunderbird46: --- → fixed
Target Milestone: --- → Thunderbird 46.0
(Assignee)

Comment 11

2 years ago
Comment on attachment 8701625 [details] [diff] [review]
msgIdentityFix.patch v2

[Approval Request Comment]
Regression caused by (bug #): 1159316
User impact if declined: some not differentiable characters like q and g
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low, only CSS changes
Attachment #8701625 - Flags: approval-comm-aurora?

Updated

2 years ago
Attachment #8701625 - Flags: approval-comm-aurora? → approval-comm-aurora+

Comment 12

2 years ago
Aurora:
https://hg.mozilla.org/releases/comm-aurora/rev/ffdc1b001548
status-thunderbird45: affected → fixed

Updated

2 years ago
tracking-thunderbird45: ? → +
You need to log in before you can comment on or make changes to this bug.