Closed Bug 1232769 Opened 5 years ago Closed 5 years ago

Changing a bookmark's keyword cannot be reverted

Categories

(Toolkit :: Places, defect)

43 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1179076

People

(Reporter: chrismendez, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151208100201

Steps to reproduce:

1. Show all bookmarks
2. Navigate to and show properties for a keyword search bookmark
3. Change the keyword. For example, from "mysearch" to "mysearch2"
4. Navigate away to another bookmark, and then navigate back
5. Change the keyword back to the original value. For example, "mysearch2" to "mysearch".
6. Navigate away to another bookmark, and then navigate back
7. Look at the Keyword field -- it reverted back to "mysearch2".



Actual results:

It appears that changing the keyword of a bookmark prevents the old keyword from being used again.


Expected results:

It should let me change Keywords when there's no obvious conflict, and it should show an error describing why it's throwing away my change.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
OS: Unspecified → Windows 7
Resolution: --- → DUPLICATE
Duplicate of bug: 1179076
Component: Untriaged → Places
OS: Windows 7 → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
You need to log in before you can comment on or make changes to this bug.