Closed Bug 12328 Opened 20 years ago Closed 20 years ago

[QA Blocker] Crash when opening compose window

Categories

(MailNews Core :: Composition, defect, P3, blocker)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: scottputterman, Assigned: rods)

References

Details

run mailnews. apprunner -mail
Click the new msg button.
Crash with the following stack:

      if (comboboxFrame) {
        nsIFrame * listFrame;
      ===>  comboboxFrame->GetDropDown(&listFrame);
        if (nsnull != listFrame) {
          listFrame->FirstChild(nsnull, &frame);
        }
      }

nsCSSFrameConstructor::GetFrameFor(nsIPresShell * 0x03631650, nsIPresContext *
0x0360bc90, nsIContent * 0x03ebe1b0) line 4538 + 7 bytes
nsCSSFrameConstructor::ContentAppended(nsCSSFrameConstructor * const 0x03631740,
nsIPresContext * 0x0360bc90, nsIContent * 0x03ebe1b0, int 0) line 4749 + 25
bytes
StyleSetImpl::ContentAppended(StyleSetImpl * const 0x036317e0, nsIPresContext *
0x0360bc90, nsIContent * 0x03ebe1b0, int 0) line 790
PresShell::ContentAppended(PresShell * const 0x03631658, nsIDocument *
0x036005a0, nsIContent * 0x03ebe1b0, int 0) line 1562 + 46 bytes
XULDocumentImpl::ContentAppended(XULDocumentImpl * const 0x036005a0, nsIContent
* 0x03ebe1b0, int 0) line 1962
nsGenericHTMLContainerElement::AppendChildTo(nsIContent * 0x03f5bbac, int 1)
line 2781
nsGenericHTMLContainerElement::InsertBefore(nsIDOMNode * 0x03f5bba0, nsIDOMNode
* 0x00000000, nsIDOMNode * * 0x0012d590) line 2462 + 14 bytes
nsGenericHTMLContainerElement::AppendChild(nsIDOMNode * 0x03f5bba0, nsIDOMNode *
* 0x0012d590) line 2621
nsHTMLSelectElement::Add(nsHTMLSelectElement * const 0x03ebe1a0,
nsIDOMHTMLElement * 0x03f5bba0, nsIDOMHTMLElement * 0x00000000) line 312 + 19
bytes
HTMLSelectElementAdd(JSContext * 0x02e6f840, JSObject * 0x037a8e80, unsigned int
2, long * 0x011960a8, long * 0x0012d6dc) line 542 + 33 bytes
js_Invoke(JSContext * 0x02e6f840, unsigned int 2, unsigned int 0) line 654 + 26
bytes
js_Interpret(JSContext * 0x02e6f840, long * 0x0012df08) line 2228 + 15 bytes
js_Invoke(JSContext * 0x02e6f840, unsigned int 1, unsigned int 0) line 670 + 13
bytes
js_Interpret(JSContext * 0x02e6f840, long * 0x0012e6f0) line 2228 + 15 bytes
js_Invoke(JSContext * 0x02e6f840, unsigned int 0, unsigned int 0) line 670 + 13
bytes
js_Interpret(JSContext * 0x02e6f840, long * 0x0012eed8) line 2228 + 15 bytes
js_Invoke(JSContext * 0x02e6f840, unsigned int 1, unsigned int 2) line 670 + 13
bytes
js_InternalCall(JSContext * 0x02e6f840, JSObject * 0x012457f8, long 19159040,
unsigned int 1, long * 0x0012f03c, long * 0x0012f048) line 747 + 15 bytes
JS_CallFunctionValue(JSContext * 0x02e6f840, JSObject * 0x012457f8, long
19159040, unsigned int 1, long * 0x0012f03c, long * 0x0012f048) line 2643 + 29
bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x0360d130) line 110 + 40 bytes
nsEventListenerManager::HandleEvent(nsIPresContext & {...}, nsEvent *
0x0012f234, nsIDOMEvent * * 0x0012f1e0, unsigned int 3, nsEventStatus &
nsEventStatus_eIgnore) line 913 + 21 bytes
RDFElementImpl::HandleDOMEvent(RDFElementImpl * const 0x03e3c160, nsIPresContext
& {...}, nsEvent * 0x0012f234, nsIDOMEvent * * 0x0012f1e0, unsigned int 1,
nsEventStatus & nsEventStatus_eIgnore) line 2725
RDFElementImpl::ExecuteJSCode(nsIDOMElement * 0x03e3c150) line 3136
RDFElementImpl::ExecuteOnChangeHandler(nsIDOMElement * 0x03e33180, const
nsString & {"ready"}) line 3059 + 14 bytes
RDFElementImpl::SetAttribute(RDFElementImpl * const 0x03e3c590, int 0, nsIAtom *
0x03e3ddb0 {"ready"}, const nsString & {"true"}, int 1) line 2267
RDFXULBuilderImpl::AddAttribute(nsIContent * 0x03e3c590, nsIRDFResource *
0x03e3ffe0, nsIRDFNode * 0x02b3fa50) line 2728 + 31 bytes
RDFXULBuilderImpl::OnChange(RDFXULBuilderImpl * const 0x03e325a4, nsIRDFResource
* 0x03dc6b90, nsIRDFResource * 0x03e3ffe0, nsIRDFNode * 0x02ae9740, nsIRDFNode *
0x02b3fa50) line 1258 + 31 bytes
CompositeDataSourceImpl::OnChange(CompositeDataSourceImpl * const 0x03e33d34,
nsIRDFResource * 0x03dc6b90, nsIRDFResource * 0x03e3ffe0, nsIRDFNode *
0x02ae9740, nsIRDFNode * 0x02b3fa50) line 1417
InMemoryDataSource::Change(InMemoryDataSource * const 0x0360a8b0, nsIRDFResource
* 0x03dc6b90, nsIRDFResource * 0x03e3ffe0, nsIRDFNode * 0x02ae9740, nsIRDFNode *
0x02b3fa50) line 1241
CompositeDataSourceImpl::Change(CompositeDataSourceImpl * const 0x03e33d30,
nsIRDFResource * 0x03dc6b90, nsIRDFResource * 0x03e3ffe0, nsIRDFNode *
0x02ae9740, nsIRDFNode * 0x02b3fa50) line 946 + 28 bytes
RDFXULBuilderImpl::OnSetAttribute(RDFXULBuilderImpl * const 0x03e325ac,
nsIDOMElement * 0x03e3c580, const nsString & {"ready"}, const nsString &
{"true"}) line 1707 + 71 bytes
XULDocumentImpl::OnSetAttribute(XULDocumentImpl * const 0x036005c8,
nsIDOMElement * 0x03e3c580, const nsString & {"ready"}, const nsString &
{"true"}) line 3757
RDFElementImpl::SetAttribute(RDFElementImpl * const 0x03e3c580, const nsString &
{"ready"}, const nsString & {"true"}) line 1099
setAttribute(nsIWebShell * 0x036225c0, const char * 0x027dff88, const char *
0x027dff80, const nsString & {"true"}) line 259 + 57 bytes
nsArgCallbacks::ConstructBeforeJavaScript(nsArgCallbacks * const 0x03455f40,
nsIWebShell * 0x036225c0) line 291 + 41 bytes
nsWebShellWindow::ExecuteStartupCode() line 2216
*** Bug 12329 has been marked as a duplicate of this bug. ***
The crash occurs when we try to add dynamically a nes option to a drop down menu
from JS in MsgComposeCommands.js:

function fillIdentitySelect(selectElement)
{
    var identities = GetIdentities();

    for (var i=0; i<identities.length; i++)
    {
		var identity = identities[i];
		var opt = new Option(identity.identityName, identity.key);

		selectElement.add(opt, null); <== CRASH !!
    }
}
Summary: Crash when opening compose window → [QA Blocker] Crash when opening compose window
I think this is all platforms?
I think I just checked in a fix for this.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Works fine again on Mac with Rods' fix.
Yeah, it was all platforms.  It looks like it works not on Mac and Windows.
I'll assume it works on Linux as well.  I'll mark it fixed to get it off the
radar.  Thanks Rod.
I hate typos.  My last comment should have been it works now on Mac and Windows.
(yup. linux is fixed too)
Status: RESOLVED → VERIFIED
Target Milestone: M10
marking verified per Scott and Alec's comments.  QA isn't looking at M10 right
now - we're still looking at M9.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.