crash in mozilla::ipc::FatalError | mozilla::gmp::PGMPAudioDecoderParent::Read

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: GMP
P1
critical
Rank:
15
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: mats, Unassigned)

Tracking

({crash, regression})

45 Branch
x86_64
Windows NT
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-59285d9c-71ae-4e91-ae65-a9e532151215.
=============================================================

This looks like a recent regression in v45, starting in build 20151030030236.
143 crashes in the past 28 days, all on *64-bit* Windows:
Windows 7	44.06%	63
Windows 10	30.77%	44
Windows 8.1	23.08%	33
Windows 8	2.10%	3


Stack:
mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool)
mozilla::gmp::PGMPAudioDecoderParent::Read(mozilla::gmp::GMPAudioDecodedSampleData*, IPC::Message const*, void**)
mozilla::gmp::PGMPAudioDecoderParent::OnMessageReceived(IPC::Message const&)
mozilla::gmp::PGMPContentParent::OnMessageReceived(IPC::Message const&)
mozilla::ipc::MessageChannel::DispatchAsyncMessage(IPC::Message const&)
mozilla::ipc::MessageChannel::DispatchMessageW(IPC::Message const&)
mozilla::ipc::MessageChannel::OnMaybeDequeueOne()
RunnableMethod<SoftwareDisplay, void ( SoftwareDisplay::*)(void), mozilla::Tuple<> >::Run()
MessageLoop::DoWork()
mozilla::ipc::DoWorkRunnable::Run()
nsThread::ProcessNextEvent(bool, bool*)
NS_ProcessNextEvent(nsIThread*, bool)
mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*)
MessageLoop::RunHandler()
MessageLoop::Run()

More reports at:
https://crash-stats.mozilla.com/report/list?product=Firefox&signature=mozilla%3A%3Aipc%3A%3AFatalError+%7C+mozilla%3A%3Agmp%3A%3APGMPAudioDecoderParent%3A%3ARead
Chris/Anthony - this is in your area of GMP - AudioDecoding.  WIn64 only, and appears to be a recent regression per Mats.  Can you find an owner?
Rank: 15
Flags: needinfo?(cpearce)
Flags: needinfo?(ajones)
Priority: -- → P1
Hardware: Unspecified → x86_64
I expect this is caused by bug 1236756. We're disabling the feature that runs this code in bug 1237145, so this signature will disappear for a while.
Depends on: 1236756
Flags: needinfo?(cpearce)
Flags: needinfo?(ajones)
Fixed either by bug 1236756 or bug 1237145; signature is gone except for ancient builds
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.