Arguments objects are not iterable

RESOLVED DUPLICATE of bug 1067049

Status

()

RESOLVED DUPLICATE of bug 1067049
3 years ago
3 years ago

People

(Reporter: ljharb, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/601.2.7 (KHTML, like Gecko) Version/9.0.1 Safari/601.2.7

Steps to reproduce:

`(function () { for (let a of arguments) { console.log(a); } }(1,2,3))`


Actual results:

TypeError: arguments is not iterable


Expected results:

iterating arguments, which should have `Symbol.iterator` defined.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1067049
You need to log in before you can comment on or make changes to this bug.