Status

()

defect
P2
normal
VERIFIED INVALID
21 years ago
8 months ago

People

(Reporter: kipp, Assigned: buster)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

21 years ago
BR tags in navigator look alot like margins. In fact, the presence of a BR will
cause the object that follows top-margin to be collapsed with the vertical
distance applied by the BR. (Examples include <BR CLEAR=ALL><P>)
Reporter

Comment 1

21 years ago
java.sun.com exhibits this behavior (see j:/html/640-5.html)
Reporter

Updated

21 years ago
Status: NEW → ASSIGNED
I don't think BR tags should collapse...and I don't think they do in IE.
The BR element should not be treated as a special case. It is an element just
like any other (albeit empty, like <IMG> and <HR>).

You should simply give it its behaviour using CSS:

   BR:before { content: "\A"; }

This would result in the solving of all margin collapse issues, since it would
then act identical to all other elements.

See also bug #2590.

Comment 4

21 years ago
Setting all current Open/Normal to M4.

Comment 5

21 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
Reporter

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → INVALID
Reporter

Comment 6

20 years ago
This was mostly a note to myself about how one might treat br clear=... I don't
need the note anymore.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 7

14 years ago
Revised delivery date - 07/14

Comment 8

14 years ago
Sorry error - The revised delivery date is 07/21
No idea what you're talking about, but it probably doesn't belong on this bug.

Updated

8 months ago
Duplicate of this bug: 1493064
You need to log in before you can comment on or make changes to this bug.