Crash when adding a new criteria to or scrolling through a long criteria list in a filter

VERIFIED DUPLICATE of bug 108922

Status

MailNews Core
Filters
--
critical
VERIFIED DUPLICATE of bug 108922
16 years ago
10 years ago

People

(Reporter: Aleksander Adamowski, Assigned: Navin Gupta)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I have a message filter with a long list of criteria.
After I add a new criterium, and try to click 'OK', Mozilla crashes.
It also crashes, when I scroll forward and back through this list.
It looks just like bug 110165, but it occurs in message filter editor.
My set of rules:
1. In my prefs.js, I have the following custom headers registered:
user_pref("mailnews.customHeaders", "Mailing-List: List-Id: Reply-To:
X-Mailing-List: Return-Path");
2. my rules.dat for my IMAP e-mail account contains this rule:
name="Announce"
enabled="yes"
type="1"
action="Move to folder"
actionValue="imap://olo@nmail.altkom.com.pl/OLO/Announce"
condition="OR (\"Mailing-List\",contains,contact stunnel-announce-help@mirt.net)
OR (\"Mailing-List\",contains,httpd.apache.org) OR (to,contains,postgresql.org)
OR (from,contains,lists.mysql.com) OR (\"Mailing-List\",contains,1/22/2002) OR
(\"Reply-To\",contains,1/22/2002) OR \"X-Mailing-List\",contains,postgresql.org)
OR (\"Mailing-List\",contains,lists.mysql.com) OR
(\"List-Id\",contains,announce.mysql.com) OR
(from,contains,pgsql-announce-owner@postgresql.org) OR
(to,contains,postfix-announce@postfix.org)"

The crash occurs when i edit this rule.
(Reporter)

Comment 1

16 years ago
Talkback IDs:
When added a new criterion and clicked 'OK':
TB2477559Q
TB2477691W
When scrolling through criteria list:
TB2478006W

Updated

16 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 2

16 years ago
Oops, this bug seems as a probable dupe of bug 108922.

Comment 3

16 years ago
Actually dup of either bug 108922, bug 118815, bug 122278 or bug 122803.
This is a popular bug. Resolving as dup of one of them.

*** This bug has been marked as a duplicate of 108922 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified as duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.