Closed Bug 1233016 Opened 4 years ago Closed 4 years ago

(about:profiles) in latest inbound x64 the 'Create a New Profile' button has no functionality and there's no 'Rename' button

Categories

(Firefox :: General, defect)

46 Branch
x86_64
Unspecified
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 46
Tracking Status
firefox46 --- fixed

People

(Reporter: rick3162, Assigned: baku)

References

Details

(Keywords: 64bit, regression)

Attachments

(2 files)

Attached image screenshot.jpg
Since yesterday where the patches for replacing Profile Manager with about:profiles have landed 
and bugs 1179129 and 1232629 are marked as FIXED,
the UI is like this: https://i.imgur.com/TISBRLZ.jpg
(also see attachment)

The issue is that the 'Create a New Profile' button has no functionality  and there's no 'Rename' button.

Using inbound, 46.0a1 x64 (in win10 x64)
current changeset: https://hg.mozilla.org/integration/mozilla-inbound/rev/0bff21e6da0724c70f394e7835db1577fb302dcc
using these two addons: Greasemonkey 2015.11.20.nightly and AdBlock Plus 2.7.
Disabling them both,
and even launching Firefox via
> C:\Program Files\Nightly\firefox.exe" -no-remote -profilemanager
I get the same UI with above.


The issue only appears in x64 builds.
(inbound win32 both buttons are displayed and work ok: 
https://i.imgur.com/nVcpVuG.jpg )
Marking NEW
Blocks: 1179129
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 64bit, regression
An additional confirmation.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
My browser console shows the following error when I go into about:profiles

09:34:04.157 NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIToolkitProfileService.defaultProfile]1 aboutProfiles.js:38:0
Can this somehow be merged with Bug 1233431?
Assignee: nobody → amarchesini
Attached patch profileA.patchSplinter Review
Attachment #8699883 - Flags: review?(ehsan)
Attachment #8699883 - Flags: review?(ehsan) → review+
Duplicate of this bug: 1233800
https://hg.mozilla.org/mozilla-central/rev/2400272b81cf
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
¡Hola!

This works on Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0 ID:20151223030323 CSet: 35b211eaad1fa828064514c547057e4400e24459

¡Gracias!
Status: RESOLVED → VERIFIED
QA Whiteboard: [bugday-20151223]
[bugday-20160323]

Status: RESOLVED,FIXED -> VERIFIED

Comments:
Test is successful for 32 bits builds.


Component: 
Name			Firefox
Version			46.0b9
Build ID		20160322075646
Update Channel	        beta
User Agent		Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
OS			Windows 7 SP1 x86_64

Expected Results: 
Worked for 32bits builds.

Actual Results: 
As expected
You need to log in before you can comment on or make changes to this bug.