Closed Bug 1233046 Opened 4 years ago Closed 4 years ago

[MAC] ”This demo requires the OES_texture_float extension” error for WebGL animation

Categories

(Core :: Canvas: WebGL, defect)

All
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox44 --- wontfix
firefox45 + fixed
firefox46 + fixed
firefox47 --- fixed

People

(Reporter: vasilica.mihasca, Assigned: jgilbert)

References

Details

(Keywords: regression, Whiteboard: gfx-noted)

Attachments

(4 files, 3 obsolete files)

Reproducible on: Firefox 46.0a1 and Firefox 45.0a2 under Mac

STR
1.Launch Firefox with a clean profile.
2.Navigate to http://madebyevan.com/webgl-water/

ER
The WebGL animation is loaded and no errors are encountered.

AR
“Error: This demo requires the OES_texture_float extension” error is displayed.
See screenshot: http://i.imgur.com/NHedNYj.png

Additional notes:
- Reproducible on: Firefox 46.0a1 (2015-12-16) and Firefox 44.0a2 (2015-12-16) using Mac OS X 10.9.5
- This issue is a regression because it is not reproducible on Firefox 43.0a2
- I will provide a regression window as soon as possible
Regression window:

- Last good revision: 390cb35d92453aeccb0acf85dc113616f1006be1
- First bad revision: 7d1c223f397cdbcf494a4ef7ff7e56a5100b14c2
- Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=390cb35d92453aeccb0acf85dc113616f1006be1&tochange=7d1c223f397cdbcf494a4ef7ff7e56a5100b14c2

This issue was caused by Bug 1221822
Flags: needinfo?(jgilbert)
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
Summary: ”This demo requires the OES_texture_float extension” error for WebGL animation → [MAC] ”This demo requires the OES_texture_float extension” error for WebGL animation
Whiteboard: gfx-noted
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca][PTO until 4 January] from comment #0)
> Reproducible on: Firefox 46.0a1 and Firefox 45.0a2 under Mac
> 
> STR
> 1.Launch Firefox with a clean profile.
> 2.Navigate to http://madebyevan.com/webgl-water/
> 
> ER
> The WebGL animation is loaded and no errors are encountered.
> 
> AR
> “Error: This demo requires the OES_texture_float extension” error is
> displayed.
> See screenshot: http://i.imgur.com/NHedNYj.png
> 
> Additional notes:
> - Reproducible on: Firefox 46.0a1 (2015-12-16) and Firefox 44.0a2
> (2015-12-16) using Mac OS X 10.9.5
> - This issue is a regression because it is not reproducible on Firefox 43.0a2
> - I will provide a regression window as soon as possible

Wait, 44 is affected, or just 45+?
Flags: needinfo?(jgilbert) → needinfo?(vasilica.mihasca)
Sorry for the typo - it’s Firefox 45.0a2 from 2015-12-16, not Firefox 44.0a2.

But, just to be sure, I checked again on Firefox 46.0a1 (2016-01-03) and Firefox 45.0a2 (2016-01-03) and these versions are still affected.
This issue is *not* reproducible on Firefox 44 beta 4.
Flags: needinfo?(vasilica.mihasca)
Alright, I see what this is.

Post-texture-refactor, in the TextureFloat extension's IsSupported, we require texture_swizzle if !gles. We shouldn't need swizzling for Compatibility profiles.

FWIW, if we requested a Core profile, we should be getting ARB_texture_swizzle.

We should not require swizzling on Compat profiles, though.
Assignee: nobody → jgilbert
Attachment #8710821 - Flags: review?(jmuizelaar)
Attachment #8710821 - Flags: review?(jmuizelaar) → review+
Attachment #8710821 - Attachment is obsolete: true
Attachment #8713368 - Flags: review?(jmuizelaar)
Comment on attachment 8713368 [details] [diff] [review]
0002-Don-t-query-GL_-_BITS-on-Core-profiles.patch

I'll make a different bug for this.
Attachment #8713368 - Attachment is obsolete: true
Attachment #8713368 - Flags: review?(jmuizelaar)
I'm sending this branch to Try to have it tell me which extensions are enabled where.
Attachment #8713375 - Flags: review?(jmuizelaar)
And here's the working iteration:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=d846f3b7358a
Attachment #8713375 - Attachment is obsolete: true
Attachment #8713375 - Flags: review?(jmuizelaar)
Attachment #8713895 - Flags: review?(jmuizelaar)
A more fun demo: http://www.edankwan.com/experiments/the-spirit/ that should work once we get this implemented.
[Tracking Requested - why for this release]: This is a regression from 44.
Flags: needinfo?(jmuizelaar)
Attachment #8713895 - Flags: review?(jmuizelaar) → review+
Attachment #8713372 - Flags: review?(jmuizelaar) → review+
Attachment #8713367 - Flags: review?(jmuizelaar) → review+
Duplicate of this bug: 1245631
Comment on attachment 8713367 [details] [diff] [review]
0001-Support-both-needing-swizzle-and-just-needing-sized-.patch

Approval Request Comment
[Feature/regressing bug #]: bug 1221822
[User impact if declined]: No float-textures in WebGL on OSX, which prevents some sophisticated functionality.
[Describe test coverage new/current, TreeHerder]: Tests included.
[Risks and why]: Low. At worst, it just doesn't fix it, and it stays disabled.
[String/UUID change made/needed]: none
Flags: needinfo?(jgilbert)
Attachment #8713367 - Flags: approval-mozilla-beta?
Attachment #8713367 - Flags: approval-mozilla-aurora?
(In reply to Wes Kocher (:KWierso) from comment #16)
> Also seems to have busted gl tests on OSX:
> https://treeherder.mozilla.org/logviewer.html#?job_id=21021624&repo=mozilla-
> inbound

Ugh, 10.10. Try only checks 10.6 or .8 these days I guess.
Flags: needinfo?(jmuizelaar)
Jeff, you request the uplift for one patch or all four?
Thanks
Flags: needinfo?(jgilbert)
Flags: qe-verify+
(In reply to Sylvestre Ledru [:sylvestre] from comment #23)
> Jeff, you request the uplift for one patch or all four?
> Thanks

All four. I can upload a single diff for this, if that's preferred.
Flags: needinfo?(jgilbert)
Duplicate of this bug: 1245850
Comment on attachment 8713367 [details] [diff] [review]
0001-Support-both-needing-swizzle-and-just-needing-sized-.patch

Afaik, this is not a regression. So, I am going to let it ride the train from 46.
Attachment #8713367 - Flags: approval-mozilla-beta?
Attachment #8713367 - Flags: approval-mozilla-beta-
Attachment #8713367 - Flags: approval-mozilla-aurora?
Attachment #8713367 - Flags: approval-mozilla-aurora+
Comment on attachment 8713372 [details] [diff] [review]
0004-Add-requestFlakeyTimeout-to-SimpleTest-shim-in-mochi.patch

[Triage Comment]
Attachment #8713372 - Flags: approval-mozilla-aurora+
Comment on attachment 8713895 [details] [diff] [review]
0005-Add-ensure-extension-tests.patch

[Triage Comment]
Attachment #8713895 - Flags: approval-mozilla-aurora+
Attachment #8715627 - Flags: approval-mozilla-aurora+
(In reply to Sylvestre Ledru [:sylvestre] from comment #26)
> Comment on attachment 8713367 [details] [diff] [review]
> 0001-Support-both-needing-swizzle-and-just-needing-sized-.patch
> 
> Afaik, this is not a regression. So, I am going to let it ride the train
> from 46.

Not sure if your comment refers to that specific patch, or this bug overall. This bug is a regression, see https://bugzilla.mozilla.org/show_bug.cgi?id=1245850 which was marked as duplicate of this bug.
(In reply to Sylvestre Ledru [:sylvestre] from comment #26)
> Comment on attachment 8713367 [details] [diff] [review]
> 0001-Support-both-needing-swizzle-and-just-needing-sized-.patch
> 
> Afaik, this is not a regression. So, I am going to let it ride the train
> from 46.

It is actually a regression, in that it used to work fine until late 2015. I do think we should take this.
Flags: needinfo?(sledru)
Comment on attachment 8713367 [details] [diff] [review]
0001-Support-both-needing-swizzle-and-just-needing-sized-.patch

OK, let's take it then.
Flags: needinfo?(sledru)
Attachment #8713367 - Flags: approval-mozilla-beta- → approval-mozilla-beta+
Attachment #8713372 - Flags: approval-mozilla-beta+
Attachment #8713895 - Flags: approval-mozilla-beta+
Attachment #8715627 - Flags: approval-mozilla-beta+
QA Whiteboard: [good first verify]
Flags: qe-verify+
[bugday-20160323]

Able to get expected results for:

Status: RESOLVED,FIXED -> VERIFIED

Component: 
Name 	        Firefox
Version 	46.0b2
Build ID 	20160314144540
Update Channel 	beta
User Agent 	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
OS              Windows 7 SP1 x86_64

Actual Results: 
As expected

Expected Results: 
All interactions are working for OpenGL and no error has occurred.
Not reproducible for 46.0b2.
Tested on Mac OS X 10.9.5 on the build from 2015-12-16, it was reproducible.
Retested in on 47.0b3 and the bug was fixed.
[testday-20160506]
You need to log in before you can comment on or make changes to this bug.