Closed Bug 1233110 Opened 6 years ago Closed 6 years ago

Youtube scrubber is not functioning

Categories

(Toolkit :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

VERIFIED FIXED
blocking-b2g 2.6+
Tracking Status
b2g-v2.5 --- unaffected
b2g-master --- verified

People

(Reporter: vbelonenko, Unassigned)

References

()

Details

(Keywords: regression, smoketest, Whiteboard: [2.6-Daily-Testing][Spark] [dogfood-blocker])

Attachments

(1 file)

Description:
Playing video on browser youtube.com and scrolling with cursor left to right, the video would not skip at all. Cursor does not function.

Repro Steps:
1) Update a Aries to 20151216121527
2) Go to youtube.com
3) Play Video Scroll cursor left to right
4) Observe that cursor does not slide left or right and video does not skips.

Actual:
When sliding cursor on YouTube videos, the cursor does not work properly.

Expected:
Youtube vidoes should skip when user slides with cursor.

Environmental Variables:
Device: Aries Master 2.6 kk full flash
Build ID: 20151216121527
Gaia: a84c2dbe672583914d04380cd61a56f1c60c3b8e
Gecko: 0babaa3edcf908c393b68a3dc2d1c2a2450c31ed
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Repro frequency: 3/3
See attached: video clip and logcat
Major regression in Youtube.  Let's get a window here.
blocking-b2g: --- → 2.6?
QA Contact: pcheng
This issue still occurs on Flame 2.6
Result: When sliding cursor on YouTube videos, the cursor does not work properly.

Environmental Variables:
Device: Flame 2.6 kk full flash
Build ID: 20151216030223
Gaia: a84c2dbe672583914d04380cd61a56f1c60c3b8e
Gecko: 0babaa3edcf908c393b68a3dc2d1c2a2450c31ed
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46

This issue does not occurs on Flame 2.5 
Result: YouTube video skips when user slides with cursor.

Environmental Variables:
Device: Flame 2.5 kk full flash
Build ID: 20151216102959
Gaia: 062e0fa48c1b5d5156f6911a5a4519128fac3231
Gecko: ff08f85000b57964f04d4421c01784d22e0f6316
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
Summary: Sliding cursor to the right and left on YouTube.com, video does not skips → Youtube scrubber is not functioning
Whiteboard: [2.6-Daily-Testing][Systemsfe][Spark] → [2.6-Daily-Testing][Systemsfe][Spark] [dogfood-blocker]
mozilla-inbound regression window:

Last Working
Device: Flame 2.6
BuildID: 20151215094931
Gaia: ee43a95f2bbe39c5ac8c9fcdec76749a56c02f2e
Gecko: ec86fd78c9583ef3698dbbb441f53d30b0c7e151
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

First Broken
Device: Flame 2.6
BuildID: 20151215103629
Gaia: ee43a95f2bbe39c5ac8c9fcdec76749a56c02f2e
Gecko: d897127c0000a478c24e29ce10f85837a16450c6
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ec86fd78c9583ef3698dbbb441f53d30b0c7e151&tochange=d897127c0000a478c24e29ce10f85837a16450c6

This issue appears to be caused by changes made in Bug 1231828.
Blocks: 1231828
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Dave this issue seems to have been caused by the changes for bug 1231828.  Can you please take a look?
Flags: needinfo?(dtownsend)
I've backed out the piece of bug 1231828 that I expect to be causing the problem.
Flags: needinfo?(dtownsend)
Component: Gaia::Browser → General
Product: Firefox OS → Toolkit
Whiteboard: [2.6-Daily-Testing][Systemsfe][Spark] [dogfood-blocker] → [2.6-Daily-Testing][Spark] [dogfood-blocker]
blocking-b2g: 2.6? → 2.6+
Lets re-test and close this bug based on comment 5.
Keywords: qawanted, verifyme
This issue is fixed by the back out mentioned in comment 5.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This issue is verified fixed on the latest Aries and Flame 2.6 builds.
The user is able to properly scrub forward and backward in a youtube video using the scrub slider.

Environmental Variables:
Device: Aries 2.6
BuildID: 20151217122751
Gaia: 140f6ee998b07b354d1841fed902056179c90100
Gecko: 0711218a018d912036f7d3be2ae2649e213cfb85
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Environmental Variables:
Device: Flame 2.6
BuildID: 20151217030228
Gaia: 140f6ee998b07b354d1841fed902056179c90100
Gecko: f143af51f6e35932927b8ccac2509facbbe7b539
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted, verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.