Importing nonexistent CSS files beginning with "/" halts rendering of page

VERIFIED DUPLICATE of bug 148046

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 148046
16 years ago
16 years ago

People

(Reporter: Jonas Jørgensen, Assigned: dbaron)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Build 2002012403, Win2k.

Open testcase 1. The word "blablabla" appears.

Open testcase 2. The word "blablabla" does not appear.
(Reporter)

Comment 1

16 years ago
Created attachment 67722 [details]
testcase 1
(Reporter)

Comment 2

16 years ago
Created attachment 67723 [details]
testcase 2
(Reporter)

Comment 3

16 years ago
Huh, that's weird. They both work if you view them online, but if you save them
and try opening them locally, only testcase 1 works.
(Assignee)

Comment 4

16 years ago
Does this seem like a CSS loader problem or a networking problem (difference in
the way protocols work)?
worksforme (saved to local file, then loaded) with linux build 2002-02-02-22.

Setting to Win2k since this may be a windows-only bug...

Jonas, could you try a current build?
OS: All → Windows 2000
Hardware: All → PC
(Reporter)

Comment 6

16 years ago
Reproduced with the latest build.
Also WFM on a fresh CVS Linux build.  Perhaps networking-something to do with
file:// URLs?
Keywords: testcase
This worksforme with a current Linux build (saved to local disk, opened,
everything is fine).  Is this still an issue?
(Reporter)

Comment 9

16 years ago
Boris: Still reproducable on trunk build 2002070108, win2k.
Doh.  This got fixed last night; it was apparently a Windows-only bug as
described because the file: url starting with "/" is in fact invalid on Windows
and the CSS loader failed to deal.

*** This bug has been marked as a duplicate of 148046 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 11

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.